
Sat Apr 27 04:39:27 2024 1/2 MagicPlot User Guide

MagicPlot Manual - https://magicplot.com/wiki/

Table of Contents
MagicPlot Offline Manual 1 ................................................................................................................ 

System Requirements and First Launch 1 ................................................................................... 
Getting Started: Tables, Figures, Fit Plots and Undo 1 ............................................................. 
Importing Table from Text File (ASCII) 3 ...................................................................................... 
Table Editing 5 .................................................................................................................................. 
Missing Values (NaN) in Tables and Calculations 6 .................................................................... 
Nonlinear Curve Fitting: Fit Plot 7 ................................................................................................ 
Export Curves as Table 15 .............................................................................................................. 
Setting Column Formula 16 ............................................................................................................ 
Integration 18 ................................................................................................................................... 
Differentiation 19 ............................................................................................................................. 
Fast Fourier Transform (FFT) 20 .................................................................................................... 
Axes Style Editing 23 ....................................................................................................................... 
Adding and Arranging Curves on Figure Axes 23 ....................................................................... 
Adding and Arranging Axes Boxes on a Figure 25 ...................................................................... 
Using Figure Templates 27 ............................................................................................................. 
Drawing on Figures and Fit Plots, Image Zoom and Objects Selection 29 ............................. 
Reading Plot Data, Measuring Distances, Curves Selection 31 ................................................ 
Colours and Opacity Adjustment 34 .............................................................................................. 
Creating Transparent Figures and Fit Plots 35 ........................................................................... 
Using of Dimensions Toolbar 36 .................................................................................................... 
Inserting Special Symbols and Greek Letters 37 ........................................................................ 
Point, pt (unit of measure) 39 ........................................................................................................ 
Image Export 39 ............................................................................................................................... 
Preview Image 41 ............................................................................................................................. 
Copying Images to Clipboard 41 .................................................................................................... 
Keyboard Shortcuts 42 .................................................................................................................... 



Last update: Sun Nov 8 12:20:32 2015 manual https://magicplot.com/wiki/manual?rev=1277816509

https://magicplot.com/wiki/ Printed on Sat Apr 27 04:39:27 2024



Sat Apr 27 04:39:27 2024 1/44 MagicPlot User Guide

MagicPlot Manual - https://magicplot.com/wiki/

MagicPlot Offline Manual

System Requirements and First Launch

MagicPlot is a cross-platform application based on Java technology. Java Runtime is included in the
MagicPlot distributive for Windows and Mac OS X.

Running MagicPlot on Linux/Unix

You need Java Runtime Environment (JRE) of version 11 or later to run MagicPlot 3.0. You can install
Java using the package manager or get a free compiled copy here: https://adoptopenjdk.net/.

Run MagicPlot using command: path-to-jre/bin/java -XX:MaxRAMPercentage=75 -jar
MagicPlot.jar.
Here -XX:MaxRAMPercentage=75 means maximum heap memory usage 75% of free memory.

First Launch

MagicPlot does not need any installation procedure.
Place MagicPlot executable folder to the directory you prefer.
MagicPlot preferences and registration data are stored in your operating system profile and are
individual for each account.

Opening Projects on Double Click

Windows

To make Windows open your MagicPlot project files (.mppz) in MagicPlot just open context menu of
one project file in Explorer and select Open With → Choose Program item. In the opened window
press Browse button and choose MagicPlotPro.exe or MagicPlotStudent.exe file. Select the
Always use the selected program to open this kind of file checkbox and click OK.

Mac OS X

MagicPlot project files (.mppz) will be automatically associated with MagicPlot by your operating
system.

Getting Started: Tables, Figures, Fit Plots and Undo

MagicPlot Projects contain Tables, Figures and Fit Plots. MagicPlot Project files have .mppz extension.

https://en.wikipedia.org/wiki/Java
https://en.wikipedia.org/wiki/Java
https://adoptopenjdk.net/
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Tables contain numeric or text data.
Fit Plots are intended for non-linear curve fitting and subtracting baselines.
Figures are intended to graphically represent multiple data.

Close Unused Internal Windows

Feel free to close currently unused interval windows with Tables, Figures and Fit Plots. The data will
not be deleted, the window will be closed only. You can open the closed window by double clicking on
component in Project tree.

Where to start?

In most cases you may start with importing table from text file by clicking Project → Import Text
Table menu item.

Creating Figures and Fit Plots

The easiest way to create Figure or Fit Plot is the following:

Select two columns (x and y) in Table containing your data
Select Create Figure or Create Fit Plot item in the Table context menu
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You may also use Create Figure or Create Fit Plot buttons in the toolbar.

Enter Expressions in any Numeric Field

MagicPlot can evaluate simple expressions entered in any numeric text field (brackets are supported,
see Expression Syntax for details.) For example, you can enter 12/pi in circle width and height fields
in Dimensions toolbar if you want its perimeter to be equal to 12 (remember that p=πd, where p is
perimeter and d is diameter):

Importing Table from Text File (ASCII)

Use Project → Import Text Table menu item to import table(s) from text file(s), also referred
to as ASCII file(s).
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You may select multiple files in opened standard file dialog by holding Ctrl or Shift.

If you open multiple files, you can select the file to preview in files drop-down list (in Text
Input Preview frame)
If you select incorrect file(s) by mistake, click on Open icon to open file dialog once again and
select other file(s).
You can set Create Figure or Create Fit Plot checkbox to create Figure of Fit Plot after
importing:

If you select Figure, the created Figure will contain all imported data from all files
If you select Fit Plot, one Fit Plot will be created for each imported file

You can enlarge a part of the preview plot by selecting an area by mouse (scale box zoom tool).
Use context menu of the plot to change scale zoom to default.
F5 key reloads the text file or reloads the data from clipboard.

Command Line Arguments and 'Silent' Import

MagicPlot opens files which come as the command line arguments on launch. MagicPlot Project files
(.mppz) are detected as projects, the all other files are treated as the text files and the Import dialog
is opened. The text files will be imported in the current opened project.
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The -silent key in command line forces MagicPlot to import text files without opening import dialog.
The previously used import setting are used in such case. If Fit Plot or Figure creation was selected in
Import dialog last time, the new plots will be created.
Example for Windows OS: MagicPlotPro.exe mydata.txt -silent

Please make sure that your firewall software does not block MagicPlot loopback (127.0.0.1) request.

Table Editing

In MagicPlot Tables are used to store numeric or text data depending on column type (numeric/text).

Data Types

MagicPlot supports these data types in Tables:

Format Description
Numeric 64-bit double precision floating-point numbers ( IEEE 754)
Text Unicode string with unlimited length

Data type is set for entire columns. One column may not contain data with different types.
Empty cells are equivalent to Not-a-Number values.
Values from text columns are treated as empty cells if used as numbers.

Changing Column Type

Use Set Column Type menu in column context menu to change column type (numeric/text).

Columns Numbers

Columns are enumerated starting with 1. The first 26 columns are additionally denoted with Latin
letters: A, B, C, … Y, Z, 27, 28, 29, …. You can use either numbers or letters, addressing
cells and columns in formulas.

Renaming Columns

Double click on column header to rename table column. You can also use Rename Column context
menu item or press F4.

Moving (Reordering) Columns

Hold Alt key (Option on Mac, Meta/Win on Unix-like) and drag column header to rearrange table
columns. If Alt key is not pressed, mouse dragging on header will select the columns.

https://en.wikipedia.org/wiki/IEEE754
https://en.wikipedia.org/wiki/IEEE754
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Editing Table

You can edit table cell by double clicking on it. You can enter either a number or an expression using
Expression Syntax.

Fit Column Widths

To fit the width of one column, double click on right separator line in table header. To fit several
columns widths, select multiple columns and double click on one of column separators in table
header.

See Also

Setting Column Formula
Expression Syntax
Table Sorting
Missing Values (NaN) in Tables and Calculations

Missing Values (NaN) in Tables and Calculations

In computing, NaN, which stands for Not a Number, is a value or symbol that is usually produced as a
result of an operation on invalid input operands. For example, most floating-point units are unable to
explicitly calculate the square root of negative numbers, and will instead indicate that the operation
was invalid and return a NaN result.

An invalid operation is not the same as an arithmetic overflow (which returns a positive or negative
infinity). Arithmetic operations involving NaN always produce NaN, allowing the value to propagate
through a calculation so that errors can be detected at the end without extensive testing during
intermediate stages. A NaN does not compare equal to any number or NaN.

How does a NaN appear?

There are three kinds of operations which return NaN:

Operations with a NaN as at least one operand, e.g. 1+NaN1.
Indeterminate forms2.

Divisions 0/0, ∞/∞, ∞/-∞, -∞/∞, -∞/-∞
Multiplications 0*∞, 0*(-∞)
Power 1^∞
Additions ∞+(-∞), (-∞)+∞ and equivalent subtractions.

Real operations with complex results3.
Square root of a negative number
Logarithm of a negative number
Tangent of an odd multiple of 90 degrees (or π/2 radians)
Inverse sine or cosine of a number which is less than -1 or greater than +1.
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Examples

Expression Result
0^0 1
0/0 NaN
sqrt(-1) NaN
1/0 Infinity
-1/0 -Infinity

NaN in MagicPlot Tables

In MagicPlot NaN is also used to represent empty cells in Tables.

Statistical functions ignore NaN values in Tables.

NaN in Expressions

You can use predefined constants NaN, nan or NAN in expressions to specify NaN value.

The isNaN(x) function checks if the argument is NaN.

Example

If you set a Column Formula if(col(B) >= 0, col(B), NaN), it will return only positive
values from column B. Negative values are replaced with NaN value. You can use this
expression to filter negative values if you do not want to use them in future calculations. Note
that ”Not-a-Number returned at row #” warning can be shown for such expressions.

Nonlinear Curve Fitting: Fit Plot

Creating a Fit Plot

Nonlinear least squares data fitting (nonlinear regression) can be performed using Fit Plot. To create a
Fit Plot, select your X and Y columns in Table, then select Table → Create Fit Plot in the main
menu, or use the same item in the Table context menu, or use Create Fit Plot button in the
toolbar.
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MagicPlot has been verified with NIST Datasets

National Institute of Standards and Technology (NIST) has created the Statistical Reference Datasets
Project which includes 26 datasets for testing the nonlinear fit algorithms. MagicPlot has been
successfully tested on these datasets. Our report on MagicPlot testing with NIST datasets is available
here: Report.

Fitting Methodology

'Nonlinear' means here that analytical fitting function depends nonlinearly on varying parameters (fit
parameters). Fit procedure iteratively varies the parameters of the fit function to minimize the
residual sum of squares. The nonlinear fitting algorithm needs the user to set the initial values of fit
parameters.

To fit the data, implement these steps:

Create a Fit Plot, specify Y errors in Data tab of Curve Properties dialog for the data curve, if any1.
Specify fit function by adding Fit Curves2.
Specify initial values of fit parameters (drag curves or enter accurate values)3.
Specify used X data interval4.
Run fitting5.

You can undo fit and also undo changing initial parameters as any other action using Undo function. It
is a handy feature when experimenting with different models and initial parameters.

http://www.itl.nist.gov/div898/strd/nls/nls_main.shtml
http://magicplot.com/downloads/MagicPlot-NIST-Test.pdf
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Further reading

This manual does not completely cover the complex nonlinear fitting methodology. We recommend
you to take a look at this book:

H. Motulsky and A. Christopoulos, Fitting Models to Biological Data Using Linear and Nonlinear
Regression: A Practical Guide to Curve Fitting, 2004.

Fit Function is a Sum of Fit Curves

MagicPlot considers fit function as a sum of Fit Curves. Ordinarily in peaks fitting each Fit Curve
corresponds to one peak in experimental data. Click the Add button to add new Fit Curve to the list.
There is a number of predefined Fit Curves types (Line, Parabola, Gauss, Lorentz, etc.) You can also
create a Custom Equation Fit Curve and manually enter the formula. Baseline fitting components may
be added to the fitting sum, too.

Fit Plot window contains the list of Fit Curves. Each Fit Curve in the list has three checkboxes:

Show: Specifies whether to show this Fit Curve on the plot. Active only if Baseline checkbox is
not set
Baseline: Toggles the subtracting of this Fit Curve from experimental data. You also can use
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Residual button to subtract all Fit Sum from data
Sum: Specifies whether to use this Fit Curve in sum fit function

Below the Fit Curves list, is a parameters table which shows names, values, and descriptions of
parameters relating to the selected Fit Curve.

Fitting by Sum and Fitting One Curve

MagicPlot allows two alternatives buttons to run the fit:

Fit by Sum button will fit the data with the sum of Fit Curves for which the Sum checkbox is
set. Data interval from Fit Interval tab will be used. This button must be used for example
to fit the spectrum with the sum of peaks.
Fit One Curve button will fit the data with the one currently selected Fit Curve. The
individual interval for each Fit Curve will be used. Set Edit Interval checkbox to edit
individual interval for each Fit Curve.

Copying and Pasting Fit Curves

You can copy and paste Fit Curves from one Fit Plot to another Fit Plot or Figure. You can also paste
the copied Fit Curves to the same Fit Plot to create a copy.

The copy of Fit Curves with the same parameters and styles will be created if you paste Fit
Curves to a Fit Plot.
A link to the source Fit Curves will be inserted if you paste Fit Curves in a Figure.

Fit Curves Reordering

You can reorder Fit Curves by dragging them in the table. The data curve is always drawn the first
and fit sum is drawn the last.

Setting Initial Values of Parameters

Nonlinear fitting assumes that certain initial values of parameters are set before fitting. This
procedure is very easy if you use Fit Curves of predefined types (not custom equation): you can drag
curves on the plot. Initial parameters values for each Fit Curve can also be set in the parameter table.
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Adjusting Parameters with Mouse Wheel

You can adjust Parameters in the table using mouse wheel scrolling when the mouse cursor is on the
desired parameter: Hold Ctrl key (Cmd key on Mac) and scroll. If the Shift key is also pressed the
parameter step for one wheel 'click' will be increased.

Guessing Peaks

If you are fitting a spectrum with multiple peaks, MagicPlot may automatically add and approximately
locate peaks before fitting. See Guessing Peaks for details. Guessed peaks should be used only as of
the initial estimate for fitting: don't forget to click the Fit button after peaks are added.

Parameter Locking

You can lock (fix) parameter(s) to prevent varying this parameter(s) during the fit and to prevent its
changing due to set initial values by mouse dragging (for built-in functions). Set the checkbox in Lock
column in the parameter list to lock parameter.

Parameters Joining

MagicPlot allows joining (sometimes referred to as coupling, binding, linking) of fit parameters of
different Fit Curves. See Joining the Parameters of Fit Curves for details.

Weighting of Data Points Using Y Errors

MagicPlot allows the weighting of data points with Y error data. You can specify Y error data in Fit Plot
properties dialog. If no Y error data are specified weighting is not used.
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Weights are calculated as 1 / Yerror
2 for every point. See Fitting Algorithm and Computational

Formulas for details.

Weights must be positive and finite for all points so the Y error values must be positive and non-zero
(to prevent infinite weights). MagicPlot checks this condition before fitting and shows an error
message if Y errors cannot be used to compute weights.

Specifying Fit Intervals

You can set the X intervals of the data which will be used for fitting. Data points outside these
intervals are not used to compute the minimizing residual sum of squares. You can use this feature if
some data points (especially in the beginning or the end) are inaccurate, e.g. noisy.

Select Fit Interval tab to set intervals visually or edit accurate borders values in the table.

Double click on the interval to split it
Drag the interval border to move it. If intervals intersect, they will be merged
Use context menu on the plot to create, delete and split intervals

Note: Data intervals from the Fit Interval tab are used for fitting Sum only. To set individual data
intervals for the one Curve fitting use Edit Interval checkbox.

Baseline Fitting and Extraction

Fit Interval is also usable when baseline fitting. Before baseline fitting, you can specify the interval
which does not contain any signal points and contains baseline only. Set Baseline checkboxes at
baseline Fit Curves after baseline fitting to subtract baseline from data. Then specify the whole
interval and fit the data.

Note that if you use data processing (integration, FFT, etc.) on Fit Plot, then the difference between
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the data and baseline curves (which you do see on the plot) will be processed. You can use this
behavior to exclude baseline from data before integrating, see Integration for more information.

'Data-Baseline' Table Column

The 'Data-Baseline' column is appended to the Table with initial (X and Y) data when you create a Fit
Plot. The 'Data-Baseline' column contains the difference between initial Y data and baseline
approximation (the sum of Fit Curves for which Baseline checkbox is set). It is 'Data-Baseline'
column that is actually plotted on Fit Plot as data.

Use 'Data-Baseline' column in Table if you want to process the data without baseline. This column is
also used as initial data if you use Processing menu when Fit Plot is active.

Viewing the Residual Plot

Residual means here the difference between initial data, baseline function and Fit Sum function.
MagicPlot offers two different ways to view the residual:

Press and hold the Residual button. The residual will be shown while the button is pressed.
You can use either mouse or space key (if the button is selected) to hold Residual button.
You can either set Baseline checkboxes for all summed Fit Curves to subtract them from data
and explore the residual plot

Fitting

To execute the fit click the Fit by Sum button of Fit One Curve button (see below).

MagicPlot indicates the fit process with a special window. Fitting curves are periodically updated on
the plot while fitting so you can see how fit converges.

MagicPlot shows the current iteration number and deviation decrement with two progress bars while
the fit is performed. The fit process stops when one of these progress bars reaches the end.

You can see two buttons on fit progress window:

Break Iterations: Breaks iterations after current iteration. Use this button if you suspect
that further iterations will not change the result.
Undo Fit: Breaks iterations and reverts fit parameters to their initial (before fit) values. Use
this button if you see that fit process converges to wrong result; change initial values of
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parameters and run fit again.

Fitting One Curve

You can use MagicPlot to fit the data with single selected Fit Curve by pressing Fit One Curve
button. In this case, a specific data interval for each Fit Curve is used and the main fitting data
interval (from Fit Interval tab) is ignored. Select Edit Interval checkbox in the bottom of the
Fit Plot panel to set specific fit intervals for each Fit Curve.

Because of using individual data interval this method is useful for baseline fitting. In order to fit
baseline specify the intervals which do not contain signal (peaks) and contain only noise.

Why My Fit is Not Converged?

In some cases, the fit procedure may fail to find the optimal parameters values. The actual
mathematical reason for this error is the impossibility to invert the matrix α calculated from partial
derivatives of the fit function with respect to fit parameters. This inverted matrix is used to compute
the new values of parameters for the next step of fit (like gradient descent). In most cases, this error
occurs when the matrix α is ill-conditioned or nearly singular and the inverse cannot be calculated
accurately enough with used floating-point arithmetic.

The origin of this error may be:

Fit is not converged through one or more parameters: some parameters were taking
unrealistically great values during iterations. There is no local minimum of residual sum of
squares near the initial values of these parameters. MagicPlot highlights the suspicious Fit
Curve in this case.
Mutual dependency exists between some parameters. The algorithm cannot resolve which
parameter to vary.
Fit function is ill-conditioned: the minimized residual sum of squares depends on some
parameters much more than on other ones.
Numeric overflow (or underflow) when calculating fit function with initial parameter values or on
the next steps.

Try one of the following:

Specify more accurate initial values of parameters.
Simplify the fit function (e.g. remove some peaks).
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Lock some parameters.

See Also

Fitting Algorithm and Computational Formulas
Specifying Custom Fit Equation
Using Spline for Baseline Subtraction
Joining the Parameters of Fit Curves
Guessing Peaks
Predefined Fit Curves Equations
Calculating Integrals and Statistics on Intervals using Fit Plot
Export Curves as Table

Export Curves as Table

Fit Curves and Fit Sum are treated as function equations in MagicPlot Fit Plots. But in some cases (e.
g. to export and plot fit data with other application) you may want to create (x, y) table with Fit
Curves y-values. For this purpose use Tools → Export Curves as Table menu item when Fit
Plot is active. This dialog is also available for Figures.

You can either add new Table to a Folder in current Project or export table to a text file.

Page moved to Expression Syntax.
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Setting Column Formula

There are two ways to set formula for column evaluation:

1. Select column and write formula in formula string.

2. Use Table → Set Column Formula menu item to open column formula dialog window. See
Expression Syntax for details.

Row Index

Variable i contains the current row index. Rows are enumerated from 1.

Rows Evaluation Order
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Rows are always evaluated one after another from the first to the last in the specified range.
Accordingly the row number i is incremented after each step.

Example

You can use this behavior to calculate factorial: set 1 in the first row of column A and after
that set formula cell(A, i-1) * i and rows interval from 2 to 100. Note that formula is to
be set for rows beginning from the second, and not from the first. You will get the factorial of
row number (i).

Using Table Data

There are two functions to obtain current table cell values in formula:

col(A) – returns the value of cell in column A in the current (i-th) row. Equivalent to cell(A,
i).
cell(A, 3) – returns the value in column A and row 3.

You can use either upper-case letters (A…Z, e.g. col(B)) or numbers (1, 2, 3,.., e.g. col(1)) in
columns numeration in arguments of col and cell functions.

Example

col(A) + 15 + cell(B, i+1)

Auto Recalculation on Data Change

MagicPlot can automatically recalculate formula when data in used columns are changed. Set Auto
Recalculate checkbox to enable this feature.

Example

Set formula col(A)*2 for column B and set Auto Recalculate checkbox. Column B will be
recalculated if you change values in column A or column A is updated by other formula or
processing algorithm (e.g. integral, derivative of other column).

Formula Menu in Column Context Menu

You can edit column formula and change auto recalculation mode from column context menu or menu
Table. Select exactly one column and open context menu to view this menu items.

https://en.wikipedia.org/wiki/factorial
https://en.wikipedia.org/wiki/factorial
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“Argument is out of range at row #” Warning

Some mathematical functions can be defined only on a certain interval. For example, square root
(sqrt(x)) is not defined for negative numbers (all calculations in MagicPlot are made in real
numbers, not complex). Hence if the argument of sqrt is negative, a Not-a-Number (NaN) is
returned. If a NaN value occurs in some part of formula, the result of calculation will also be a NaN,
and corresponding table cells will be empty.

The calculations are not terminated if NaN value occurs in some row(s).

In some cases you may want to check if a NaN values occurs in calculations. MagicPlot shows the
warning “Argument is out of range at row #”. This row number is the first row in which NaN value
was returned. MagicPlot also highlights the function or operator which first produces NaN value.

See Also

Expression Syntax

Integration

Open Table or Figure or Fit Plot with initial data and select Processing → Integrate menu item.
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Baseline Correction

If your initial data to be integrated contains a baseline (usually constant or linear), you may want to
subtract it from data before integrating. (A constant baseline will result in linearly growing integral.)

In such case the algorithm may be the following:

Create Fit Plot with your initial table data1.
Add a Fit Curve which simulates the baseline. You may specify a custom equation2.
Specify Fit Interval so that it contains only noise points3.
Fit the data by clicking Fit Sum button4.
Subtract the baseline fitting curve from data by checking Baseline checkbox in curves list5.
Use menu Processing → Integrate to integrate the plotted data without baseline.6.

Algorithm

To perform integration you should specify two columns: x and y. Missing values are ignored.

MagicPlot uses trapezoidal rule to compute the integral:

See Also

Data Processing and Auto Recalculation
Differentiation

Differentiation

https://en.wikipedia.org/wiki/Trapezoidal_rule
https://en.wikipedia.org/wiki/Trapezoidal_rule
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Open Table or Figure or Plot with initial data and use Processing → Differentiate menu item.

Algorithm

To perform differentiation you should specify two columns: x and y. Missing values are ignored.

MagicPlot uses central difference formula to compute the derivative:

First and last points (i=1 and i=N) are computed as follows:

See Also

Data Processing and Auto Recalculation
Integration

Fast Fourier Transform (FFT)

Open Table or Figure or Plot with initial data and use Processing → Fast Fourier Transform
menu item to perform FFT.

Fast Fourier transform algorithm computes discrete Fourier transform exactly and is used to
considerably speed up the calculations.
Note that FFT is not an approximate method of calculation.

https://en.wikipedia.org/wiki/Finite_difference
https://en.wikipedia.org/wiki/Finite_difference
https://en.wikipedia.org/wiki/FFT
https://en.wikipedia.org/wiki/FFT
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Parameters

Sampling
Interval

Sampling interval of original data Δt is used to compute the data in resulting
sampling column. MagicPlot calculates sampling interval as a difference between
second and first values in Sampling column. You can set sampling interval
manually in Sampling Interval field.
Note that using of discrete Fourier transform implies that the samples in your
original data are equally spaced in time/frequency, i.e. the sampling interval is
constant. If the sampling interval is varying or real and/or imaginary data contains
empty cells in the middle, the result of discrete Fourier transform will be incorrect.

Real,
Imaginary

Columns with real and imaginary components of data.
If your data is purely real, select <none> imaginary item

Forward /
Inverse Transform direction (here Inverse also equals to Backward)

1/N in forward
transform

Divide forward transform result by number of points N (see formulas table). If your
original data is real, you may want to additionally multiply the result by 2 to get
the true amplitudes of real signal. Also referred as Normalize in some other
applications.

Center zero
frequency

If selected, after forward Fourier transform the two parts of spectrum will be
rearranged so that the lower frequency components are in the center; the
opposite rearrangement of spectrum will be done before inverse transform if any.
Also referred as Shift FFT in some other applications.

Algorithm

MagicPlot uses the algorithm of FFT that does not necessarily require the number of points N to be an
integer power of 2, though in such a case evaluation is faster. MagicPlot uses jfftpack library (a Java
version of fftpack).

http://www.netlib.org/fftpack
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Discrete Fourier Transform Formulas

By default MagicPlot uses 'electrical engineering' convention to set the sign of the exponential phase
factor of FFT: forward transform is computed using factor -1. Most scientific applications use factor
-1 in forward transform as MagicPlot does by default. But note that the sign of exponential phase
factor in Numerical Receipts in C, 2nd edition, p. 503 and in MATLAB package in forward transform is
+1.

Factor −1 (Default)
1/N in forward

transform
Forward Transform
(Signal→Spectrum)

Inverse Transform
(Spectrum→Signal)

Checked
(Default)

Unchecked

Factor +1 (Scientific)
1/N in forward

transform
Forward Transform
(Signal→Spectrum)

Inverse Transform
(Spectrum→Signal)

Checked
(Default)

Unchecked

Here cn are complex signal components and Cn are complex spectrum components, n = 1…N. The
only difference is in the sign of exponential phase factor and 1/N multiplier.

Note: if you expect to get the original data when doing an inverse FFT of forward FFT, set the 1/N in
Forward Transform, Center Zero Frequency and Factor options the same for forward and
inverse transforms.

Amplitude and Phase Columns Formulas

Because of using atan2 function the phase is unwrapped and is in range (−π, π]. The result of
atan2(y, x) is similar to calculating the arc tangent of y/x, except that the signs of both
arguments are used to determine the quadrant of the result.

Sampling Column Formulas

Sampling column contains frequency samples if forward transform is performed and time samples in
case of inverse transform.

Center zero
frequency Formula Sampling Column Values

Unchecked
Checked

Here Δt is given sampling interval of initial data (time for FFT and frequency for IFFT), n = 1…N.

https://en.wikipedia.org/wiki/atan2
https://en.wikipedia.org/wiki/atan2
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Missing Values in the Original Data

Fourier transform implies that the original samples are uniformly distributed in time (for forward
transform) or frequency (for inverse transform).

Missing values in the middle or in beginning of original data columns are treated as zeros, the
result of Fourier transform may be incorrect.

Missing values in the end of the column are ignored.

See Also

Data Processing and Auto Recalculation

Axes Style Editing

Axes style can be set in Figure Properties window (or Fit Plot Properties for Fit Plot). This
window contains multiple tabs with axes drawing settings.

Adding and Arranging Curves on Figure Axes

The best way to create a Figure with desired data is to select x and y data columns in Table and use
Create Figure in Table context menu.
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There are different ways to add data to existing Figure:

Select x and y columns in table with data, open table context menu (right click) and select Add
to Selected Axes sub-menu. All currently opened Figures are listed in this sub-menu.
Open Figure Properties window and go to Axes Properties → Components tab. Here
you can select the Table in the project tree and press Add to Axes button.
Copy and paste Curve from Fit Plot or another Figure to your Figure.

You also can add Fit Curves or Fit Sum from Fit Plot to Figure.

Changing Curves Drawing Order

To change Curves drawing order and legend entries order open Figure Properties dialog and go
to Axes Properties → Components tab. Drag rows in table to reorder. You can also use Up and
Down buttons or press Alt + up/down keys (Option + up/down keys on Mac) to move selected row in
table up or down.

See Also

Creating a Figure
Adding and Arranging Axes Boxes on a Figure
Specifying Axis Multiplier, Prefix and Suffix
Shifting Curves on Figure and Creating 2D Waterfall
Using Figure Templates

https://magicplot.com/wiki/axis_multiplier
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Adding and Arranging Axes Boxes on a Figure

You can add a new Axes box to a Figure using the Add menu either in the Figure window or in the
Figure properties dialog.

The Add & Arrange Axes as Table menu item can also be used for arranging of the existing
Axes boxes as a table.
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'Add and Arrange Axes as Table' Dialog

This dialog opens by selecting Add & Arrange Axes as Table menu item. It may be used for
adding new Axes boxes and for arranging the existing Axes boxes without adding a new one.

Moving and Resizing of an Axes Box

Axes box can be moved and resized as any other drawn object on the Figure canvas

Click on the Axes box border to select it. The green markers identifying your selection appear.1.
Drag Axes box border to move the Axes box on Canvas.2.
Draw border marker to resize Axes Box.3.
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The Using of Dimensions Toolbar toolbar can also be used to set exact Axes box size and position.
Open the Dimensions toolbar and select an Axes box to edit the values.

See Also

Creating a Figure
Adding and Arranging Curves on Figure Axes
Specifying Axis Multiplier, Prefix and Suffix
Shifting Curves on Figure and Creating 2D Waterfall
Using Figure Templates
Drawing on Figures and Fit Plots, Image Zoom and Objects Selection

Using Figure Templates

Figure Templates is a powerful tool for reusing axes layout of previously created Figures. To use
Figure Templates, open Figure Properties window and select Templates tab.

Templates are stored in a special folder in your operating system account profile. Project files do not
contain templates; changes in Projects do not affect Templates.

https://magicplot.com/wiki/axis_multiplier
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Saving Template from Figure

To create a template from Figure open the Figure Properties window, select Templates tab and press
'Save Template' button. Then enter the new template name in opened dialog window.

MagicPlot always saves all available information in the template (not regarding on checkboxes state).

Applying Template to a Figure

To apply template to figure open the Figure Properties window and select Templates tab. Select
desired template in the saved templates list. Then check or uncheck boxes with features to apply and
click on 'Apply Template' button.

When you apply a template to Figure, the properties are copied from template to Figure. Note that
the Figure style will not be changed if you change the template after you have applied it to Figure.
The project file is standalone and you do not need the template to open project.

You can undo applying template in a standard manner (no need to close the Figure Properties
window).

See Also

Creating a Figure
Adding and Arranging Axes Boxes on a Figure



Sat Apr 27 04:39:27 2024 29/44 MagicPlot User Guide

MagicPlot Manual - https://magicplot.com/wiki/

Adding and Arranging Curves on Figure Axes
Specifying Axis Multiplier, Prefix and Suffix
Shifting Curves on Figure and Creating 2D Waterfall

Drawing on Figures and Fit Plots, Image Zoom and Objects
Selection

You can draw the following kinds of objects on Figures and Fit Plots:

Text labels with formatting support
Lines
Arrows
Rectangles
Ellipses
Inserting images

Select an appropriate instrument in the toolbar to draw an object.

The properties of selected objects can be changed in the inspector toolbar (the second row of
toolbar).

Image Zooming

If you need to precisely draw some small objects you can zoom in the image using slider in right
bottom (Pro only).

There are several alternative ways to change the image zoom:

Scroll the mouse wheel at the image zoom slider
Ctrl+scroll (Cmd+scroll on Mac) mouse wheel at blank part of plot (outside all axes boxes)
The button 1x and Alt+click (Option+click on Mac) on plot fits the image to the window.

https://magicplot.com/wiki/axis_multiplier
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Do not Confuse Scale Scrolling and Image Zoom

Scale scrolling affects the x/y scale minimum and maximum values. Use scale scrolling for
data navigation
Image zoom enlarges the entire image. Use image zoom for accurate drawing of small objects.

Objects selection

Every object can be selected by clicking on its border or inside it. Hold Ctrl key (Windows, Linux) or
Shift key (Mac OS) and click another object to add it to current selection.

Moving an Object Forward or Backward

When objects overlap, you can change the order of objects drawing. Use Bring to Front and Send
to Back items in object context menu (right click on object to open menu).

Changing Curves Order on Figure

You can change the order of drawing the curves on Figure. The curves order can be set in Figure
Properties window, Axes Properties tab → Components tab. Select desired curves in list, then
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hold Alt and press up/down arrow keys. You may also use Move Up and Move Down items in
Waterfall button menu.

Snapping to Other Objects

When you drag an object or change its size, MagicPlot will try to snap the bounds of this object to
other objects. While snapping MagicPlot shows you a red ruler and an object to which the bounds are
snapping. If you do not want to align your objects this way, hold Ctrl key to disable snapping.

See Also

Scale Scrolling for Data Navigation
Reading Plot Data, Measuring Distances, Curves Selection

Reading Plot Data, Measuring Distances, Curves Selection

MagicPlot shows mouse cursor data coordinates in status line. If you have several axes on one Figure,
cursor coordinates relative to selected axes are shown.

Crosshair Cursor

MagicPlot can draw crosshair cursor. To turn it on use View → Crosshair Cursor menu item.
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Reading Plot Data

MagicPlot denotes the data point under the mouse cursor with square brackets. The accurate table
value in this point along with table name, row and column numbers is shown in status line in the
bottom of main window in the following format:

Folder | Table [x column; y column][row] = (x value; y value)

Curve Context Menu
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Use context menu of the Curve to open table with data or to open properties dialog.

Measuring Data Distances with Scale Zoom Tool

You can use Scale Zoom tool to measure the distances on plots. MagicPlot shows the distance in
status line when you select zoom box by mouse dragging. You can press Esc or reduce box size to
zero before releasing mouse button to prevent zooming if you want only to see the distance. If
multiple axes are located under cursor MagicPlot will show the distance in terms of current axes
(showed with blue corners).

Selecting Curves in Turn Using Keyboard
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Curves on Figures and Fit Plots can be selected with mouse click. You can also select Curves in turn
using Arrow keys or Tab/Shift+Tab keys:

→ or ↓ or Tab selects the next Curve
← or ↑ or Shift+Tab selects the previous Curve.

If no Curves are selected the first pressing on these keys will select the first Curve. If the Figure
contains multiple Axes, the Curves in all Axes are accessible in turn by this method.

See Also

Scale Scrolling for Data Navigation

Colours and Opacity Adjustment

In MagicPlot you can set the opacity of each object (curve, text label, rectangle, etc.) to make it semi-
transparent. Opacity is treated as a property of object color. You can set opacity in Opacity sub-
menu in color pop-up menu which opens by clicking on color button. Opacity percentage is shown on
colour button.
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See Also

Creating Transparent Figures and Fit Plots

Creating Transparent Figures and Fit Plots

To create an image with transparent background open Figure Properties or Fit Plot
Properties dialog window and set Transparent Background radio button in Canvas tab.

The background of transparent Figures and Fit Plots is shown with a grey-and-white chequerboard. If
you are preparing a picture for a dark background you can change the colour of chequerboard to dark
grey by selecting View → Transparency Checkerboard in main menu.

In case of transparent background you can set the preview background colour in Image Preview
window.
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See Also

Colours and Opacity Adjustment

Using of Dimensions Toolbar

This toolbar is intended for precise setting of the position and size of one or more selected drawn
objects on Figure or Fit Plot.

You can open Drawing Dimensions toolbar by selecting Tools → Drawing Dimensions in main
menu. Dimensions toolbar may be left opened.

Drawing Dimensions toolbar shows the coordinates and size of currently selected object(s). You can
also specify the coordinates or size of several components.

The x value is measured from the left edge of the canvas.
The y value is measured from the top edge of the canvas.
For rectangle or ellipse the specified coordinates determine the position of the upper-left
corner.
For text label:

x determines the left edge, center or right edge of text according to text alignment of
label.
y determines the baseline position of the first line.
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For line or arrow the specified coordinates determine the position of the beginning.

Inserting Special Symbols and Greek Letters

MagicPlot supports any Unicode symbols, including Greek letters and many special symbols.

The help on inserting Greek letters and special symbols is also available in Help menu.

Typing Greek letters with Keyboard Shortcuts

To insert Greek letter type Ctrl+G (Command G on Mac OS) and then type Latin letter mentioned in
the table below.

Greek Letter Name Greek Symbol On Keyboard
(Ctrl+G, then)

Alpha Α α A a
Beta Β β B b
Gamma Γ γ G g
Delta Δ δ D d
Epsilon Ε ε E e
Zeta Ζ ζ Z z
Eta Η η H h
Theta Θ θ Q q
Theta (alt.) ϑ J
Iota Ι ι I i
Kappa Κ κ K k
Lambda Λ λ L l
Mu Μ μ M m
Nu Ν ν N n
Xi Ξ ξ X x
Omicron Ο ο O o
Pi Π π P p
Rho Ρ ρ R r
Sigma Σ σ S s
Tau Τ τ T t
Upsilon Υ υ U u
Phi Φ φ F f
Phi (alt.) ϕ j
Chi Χ χ C c
Psi Ψ ψ Y y
Omega Ω ω W w

Inserting Math Symbols with Keyboard Shortcuts

To insert math symbol type Ctrl+M (Command M on Mac OS) and then type symbol mentioned in the

https://en.wikipedia.org/wiki/Unicode
https://en.wikipedia.org/wiki/Unicode
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table below.

Symbol name Symbol On Keyboard
(Ctrl+M, then)

Multiplication sign × * or x
Middle dot (multiplication) · . (dot)
Division slash ∕ /
Minus sign − -
Plus-minus sign ± +
Minus-plus sign ∓ =
Not equal ≠ n
Infinity ∞ 8

To see the full list of shortcuts select Help → Insert Greek Letters and Math menu item.

Inserting Special Characters by Character Sequences

To insert the following special characters, simply type character sequences, as shown in the table
below. Character sequences will be replaced with special characters when you exit the edit mode (but
only if selected font contains required symbols).

You can disable auto replacing in Typography tab of MagicPlot Preferences.

Symbol name Symbol Char sequence
Em dash — ---
En dash – --
Ellipsis … ...
Much less than ≪ <<
Much greater than ≫ >>
Less than or equal to ≤ <=
Greater than or equal to ≥ >=
Plus-minus sign ± +/-
Minus-plus sign ∓ -/+

Unicode Code Point Finding out

MagicPlot shows in status bar the Unicode code point of character highlighted in text label. To
view code point select exactly one character in text label in Figure of Fit Plot.

https://en.wikipedia.org/wiki/Unicode
https://en.wikipedia.org/wiki/code point
https://en.wikipedia.org/wiki/Unicode
https://en.wikipedia.org/wiki/code point
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See Also

Advanced Typography Features

Point, pt (unit of measure)

In typography, a point is the smallest unit of width or height measure. It is commonly
abbreviated as pt.

The desktop publishing point (DTP point) is defined as 1/72 inch, it is approximately 0.0139 inch or
0.353 mm. Twelve points make up a pica, and six picas make an inch.

In MagicPlot points are used to set up font size and line widths.

Image Export

To export Figure or Fit Plot image click on Project → Export Image menu item or use
corresponding toolbar button. You can set various options of file export format by clicking on Format
Options button in Export Image dialog window.

You can also copy image to clipboard.

Raster Image Formats

The following lossless raster graphics formats are supported:

PNG — the most suitable format for Fit Plots and Figures
GIF — supports only 256 colours and no transparency, out-of-date format
BMP — uncompressed raster format (large file size)

Setting the resolution of exported raster image

Image resolution for raster export can be set individually for every Figure and Fit Plot in Canvas tab
of the Properties window. The default resolution is 300 DPI.

Why is MagicPlot not capable to export images in JPEG format?

JPEG is a commonly used format of lossy compression for photographic images. The JPEG
compression algorithm is at its best on photographs and paintings of realistic scenes with smooth
variations of tone and color. However, JPEG is not suited for line drawings and other textual or iconic
graphics, where sharp contrasts between adjacent pixels cause noticeable artefacts. Such images are
better saved in a lossless raster graphics format such as BMP, GIF, PNG or vector graphics formats.

https://en.wikipedia.org/wiki/typography
https://en.wikipedia.org/wiki/Point_(typography)
https://en.wikipedia.org/wiki/typography
https://en.wikipedia.org/wiki/Point_(typography)
https://en.wikipedia.org/wiki/desktop publishing
https://en.wikipedia.org/wiki/desktop publishing
https://en.wikipedia.org/wiki/raster graphics
https://en.wikipedia.org/wiki/raster graphics
https://en.wikipedia.org/wiki/Portable_Network_Graphics
https://en.wikipedia.org/wiki/Portable_Network_Graphics
https://en.wikipedia.org/wiki/GIF
https://en.wikipedia.org/wiki/GIF
https://en.wikipedia.org/wiki/BMP_file_format
https://en.wikipedia.org/wiki/BMP_file_format
https://en.wikipedia.org/wiki/JPEG
https://en.wikipedia.org/wiki/lossy compression
https://en.wikipedia.org/wiki/JPEG
https://en.wikipedia.org/wiki/lossy compression
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PNG and JPEG Comparison 1)

PNG JPEG

Vector Image Formats

The following vector graphics formats are supported:

PDF
EPS
SVG — most suitable for web publications
EMF — the most suitable format for inserting in Windows applications like Microsoft Office

Export in vector graphics formats by virtual printer

You also can use third-party virtual printer software to save an image in vector graphics format (use
Project → Print menu item).

Image Format Restrictions

BMP:
Transparent background is not supported.

GIF:
Transparent background is supported but semi-transparency is not. Only 256 colours.

EMF and vector copy on Windows:
No semi-transparent colors (but transparent background is supported).
Image may be opened without antialiasing in some applications.
Text tracking changing is not supported

EPS:
Transparency is available only in Acrobat Distiller. Set Allow Pdfmark Transparency
checkbox in EPS format options, add /AllowTransparency true into Acrobat Distiller's
.joboptions file.
Transparent images inserted on plots will have solid color background.

Raster image copying:
Transparent background is not supported.

See Also

Copying Images to Clipboard
Preview Image

https://en.wikipedia.org/wiki/vector graphics
https://en.wikipedia.org/wiki/vector graphics
https://en.wikipedia.org/wiki/PDF
https://en.wikipedia.org/wiki/PDF
https://en.wikipedia.org/wiki/Encapsulated_PostScript
https://en.wikipedia.org/wiki/Encapsulated_PostScript
https://en.wikipedia.org/wiki/Scalable_Vector_Graphics
https://en.wikipedia.org/wiki/Scalable_Vector_Graphics
https://en.wikipedia.org/wiki/Enhanced_Windows_Metafile
https://en.wikipedia.org/wiki/Enhanced_Windows_Metafile
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Preview Image

Use Project → Image Preview menu item to open image preview window. You can also use the
Preview button of the toolbar or Ctrl+Shift+P keyboard shortcut (Cmd+Shift+P on Mac).

Preview Features

In preview mode you can:

Preview in gray scale
Transparent images can be previewed on selected background color
Change the zoom of the image

Preview Zoom Options

There are several options for the size of preview:

Percent of real size. Note: The size will be actually real only if the dots per inch (DPI) is
correctly set in your operating system
Fit to Window, Fit Width, Fit Height — fits the size of previewed image to window
dimensions
Pixel-to-Pixel — allows you to see the accurate image that you will get using export in
raster image format. The resolution of exported raster image is evaluated as a product of
canvas size and DPI value specified in Canvas tab of Figure/Fit Plot Properties window.

Copying Images to Clipboard

When you edit a presentation or report, it is very useful to paste images from MagicPlot to another
application directly through clipboard without saving them.
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MagicPlot supports copying images to clipboard in both raster and vector formats from Edit menu.
Transferring vector images is always preferable because these images are scaled more precisely.
However, we have found that some applications do not support pasting vector images, or paste
vector images with distorted text. In this case, please use copying raster image.

See Also

Image Export

Keyboard Shortcuts

MagicPlot keyboard shortcuts are almost the same in different operating systems (Windows, Mac OS,
UNIX-like). The main difference is in modifier keys used: Ctrl on PC (Windows, UNIX-like) and
Command on Mac. Some shortcuts were altered to avoid coincidences with system ones.

You can find these keyboard shortcuts in MagicPlot by selecting Help → Keyboard Shortcuts
menu item.

Mac Keyboard Symbols

⌘ Command (Meta) key
⇧ Shift key
⌥ Option (Alt) key
⌃ Control key

Common Shortcuts

Windows and UNIX-like Key Mac OS Key Action
Ctrl+O ⌘ O Open project
Ctrl+S ⌘ S Save project
Ctrl+Shift+S ⌘ ⇧ S Save project as
Ctrl+N ⌘ N New project
Ctrl+Shift+N ⌘ ⇧ N New table
Ctrl+I ⌘ I Import table from text file
Ctrl+Shift+I ⌘ ⇧ I Import table from clipboard
Ctrl+P ⌘ P Print (image or table)
Ctrl+Shift+P ⌘ ⇧ P Preview image
Ctrl+E ⌘ E Export image or table
Ctrl+K ⌘ K Open calculator
Ctrl+U ⌘ U MagicPlot preferences
Ctrl+Q ⌘ Q Quit

Undo/Redo
Ctrl+Z ⌘ Z Undo
Ctrl+Shift+Z or Ctrl+Y ⌘ ⇧ Z or ⌘ Y Redo
Ctrl+Shift+H ⌘ ⇧ H Show command history window
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Windows and UNIX-like Key Mac OS Key Action
Clipboard

Ctrl+X ⌘ X Cut
Ctrl+C ⌘ C Copy
Ctrl+V ⌘ V Paste
Ctrl+A ⌘ A Select all

Table Shortcuts

Windows and UNIX-like Key Mac OS Key Action
F2 or Double click Double click Edit cell
Ctrl+F2 ⌘ F2 Set or edit column formula
F4 F4 Rename column (edit header)
Ctrl+Enter ⌘ Return Recalculate column
Alt+Drag header
(Win/Meta+Drag header on UNIX) ⌥ Drag header Rearrange table columns

Figure and Fit Plot Shortcuts

Windows and UNIX-like Key Mac OS Key Action
Alt+Enter ⌥ Return Open Figure or Fit Plot properties window
Arrows keys Arrows keys Move selected object(s) by 1 mm
Shift+Arrows keys ⇧ Arrows keys Move selected object(s) by 0.1 mm
Escape Escape Clear selection
Delete or Backspace Delete or Backspace Delete selected objects
F2 or Double click F2 or Double click Edit selected text label
Moving and Resizing Drawings

Ctrl+Drag object ⌘ Drag object Disable rulers and snapping to other
objects

Shift+Drag corners ⇧ Drag corners
For rectangle and ellipse: preserve aspect
ratio
For line and arrow: disable snapping to 0°,
45°, 90°…

Alt+Drag corners ⌥ Drag corners For rectangle and ellipse: stretch relative
to center

Text Labels Editing 2)

Ctrl+Enter or Shift+Enter ⌘ Return or ⇧ Return Apply changes
Escape Escape Apply changes
Enter Return New line
Ctrl+G, then letter ⌘ G, then letter Type Greek letter (letters correspondence)
Ctrl+M, then symbol ⌘ M, then symbol Type special math symbol (symbol list)
Ctrl+B ⌘ B Bold
Ctrl+I ⌘ I Italic
Ctrl+O ⌘ O Oblique
Ctrl+U ⌘ U Underlined
Ctrl+L ⌘ L Align left
Ctrl+E ⌘ E Center
Ctrl+R ⌘ R Align right
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Windows and UNIX-like Key Mac OS Key Action
Ctrl+J ⌘ J Justify
Ctrl+– ⌘ – Subscript
Ctrl++ ⌘ + Superscript
Scale Range Scrolling and Zoom
Scrolling 3) Scrolling Vertical (Y) scale scrolling

Shift+Scrolling ⇧ Scrolling or Horizontal
scrolling Horizontal (X) scale scrolling

Ctrl+Scrolling ⌘ Scrolling Vertical (Y) scale zooming

Ctrl+Shift+Scrolling ⌘ ⇧ Scrolling or ⌘
Horizontal scrolling Horizontal (X) scale zooming

Left mouse button+Scrolling ⌃ Scrolling Proportional (X and Y) scale zooming
Image Zoom
Ctrl++ ⌘ + Zoom in
Ctrl+– or Alt+Click ⌘ – or ⌥ Click Zoom out
Ctrl+* or Ctrl+0 ⌘ * or ⌘ 0 Full view

1)

If you use Opera browser with Opera Turbo option the images will appear recompressed in JPEG
format and this comparison is void.
2)

These shortcuts are activated in text label edit mode.
3)

Scrolling here means mouse wheel rotation or touchpad vertical scrolling.
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