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Overview
System Requirements and First Launch
MagicPlot is a cross-platform application based on
MagicPlot distributive for Windows and Mac OS X.

Java technology. Java Runtime is included in the

Running MagicPlot on Linux/Unix
You need Java Runtime Environment (JRE) of version 11 or later to run MagicPlot 3.0. You can install
Java using the package manager or get a free compiled copy here: https://adoptopenjdk.net/.
Run MagicPlot using command: path-to-jre/bin/java -XX:MaxRAMPercentage=75 -jar
MagicPlot.jar.
Here -XX:MaxRAMPercentage=75 means maximum heap memory usage 75% of free memory.

First Launch
MagicPlot does not need any installation procedure.
Place MagicPlot executable folder to the directory you prefer.
MagicPlot preferences and registration data are stored in your operating system proﬁle and are
individual for each account.

Opening Projects on Double Click
Windows
To make Windows open your MagicPlot project ﬁles (.mppz) in MagicPlot just open context menu of
one project ﬁle in Explorer and select Open With → Choose Program item. In the opened window
press Browse button and choose MagicPlotPro.exe or MagicPlotStudent.exe ﬁle. Select the
Always use the selected program to open this kind of file checkbox and click OK.
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Mac OS X
MagicPlot project ﬁles (.mppz) will be automatically associated with MagicPlot by your operating
system.

Getting Started: Tables, Figures, Fit Plots and Undo
MagicPlot Projects contain Tables, Figures and Fit Plots. MagicPlot Project ﬁles have .mppz extension.
Tables contain numeric or text data.
Fit Plots are intended for non-linear curve ﬁtting and subtracting baselines.
Figures are intended to graphically represent multiple data.

Close Unused Internal Windows
Feel free to close currently unused interval windows with Tables, Figures and Fit Plots. The data will
not be deleted, the window will be closed only. You can open the closed window by double clicking on
component in Project tree.

Where to start?
In most cases you may start with importing table from text ﬁle by clicking Project → Import Text
Table menu item.

Creating Figures and Fit Plots
The easiest way to create Figure or Fit Plot is the following:
Select two columns (x and y) in Table containing your data
Select Create Figure or Create Fit Plot item in the Table context menu
http://magicplot.com/wiki/
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You may also use Create Figure or Create Fit Plot buttons in the toolbar.

Enter Expressions in any Numeric Field
MagicPlot can evaluate simple expressions entered in any numeric text ﬁeld (brackets are supported,
see Expression Syntax for details.) For example, you can enter 12/pi in circle width and height ﬁelds
in Dimensions toolbar if you want its perimeter to be equal to 12 (remember that p=πd, where p is
perimeter and d is diameter):

Importing Table from Text File (ASCII)
Use Project → Import Text Table menu item to import table(s) from text ﬁle(s), also referred
to as ASCII ﬁle(s).
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You may select multiple ﬁles in opened standard ﬁle dialog by holding Ctrl or Shift.
If you open multiple ﬁles, you can select the ﬁle to preview in ﬁles drop-down list (in Text
Input Preview frame)
If you select incorrect ﬁle(s) by mistake, click on Open icon to open ﬁle dialog once again and
select other ﬁle(s).
You can set Create Figure or Create Fit Plot checkbox to create Figure of Fit Plot after
importing:
If you select Figure, the created Figure will contain all imported data from all ﬁles
If you select Fit Plot, one Fit Plot will be created for each imported ﬁle
You can enlarge a part of the preview plot by selecting an area by mouse (scale box zoom tool).
Use context menu of the plot to change scale zoom to default.
F5 key reloads the text ﬁle or reloads the data from clipboard.

Command Line Arguments and 'Silent' Import
MagicPlot opens ﬁles which come as the command line arguments on launch. MagicPlot Project ﬁles
(.mppz) are detected as projects, the all other ﬁles are treated as the text ﬁles and the Import dialog
is opened. The text ﬁles will be imported in the current opened project.
http://magicplot.com/wiki/
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The -silent key in command line forces MagicPlot to import text ﬁles without opening import dialog.
The previously used import setting are used in such case. If Fit Plot or Figure creation was selected in
Import dialog last time, the new plots will be created.
Example for Windows OS: MagicPlotPro.exe mydata.txt -silent
Please make sure that your ﬁrewall software does not block MagicPlot loopback (127.0.0.1) request.

Table Editing
In MagicPlot Tables are used to store numeric or text data depending on column type (numeric/text).
Data Types
MagicPlot supports these data types in Tables:
Format Description
Numeric 64-bit double precision ﬂoating-point numbers (
Text
Unicode string with unlimited length

IEEE 754)

Data type is set for entire columns. One column may not contain data with diﬀerent types.
Empty cells are equivalent to Not-a-Number values.
Values from text columns are treated as empty cells if used as numbers.
Changing Column Type
Use Set Column Type menu in column context menu to change column type (numeric/text).
Columns Numbers
Columns are enumerated starting with 1. The ﬁrst 26 columns are additionally denoted with Latin
letters: A, B, C, … Y, Z, 27, 28, 29, …. You can use either numbers or letters, addressing
cells and columns in formulas.
Renaming Columns
Double click on column header to rename table column. You can also use Rename Column context
menu item or press F4.
Moving (Reordering) Columns
Hold Alt key (Option on Mac, Meta/Win on Unix-like) and drag column header to rearrange table
columns. If Alt key is not pressed, mouse dragging on header will select the columns.
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Editing Table
You can edit table cell by double clicking on it. You can enter either a number or an expression using
Expression Syntax.
Fit Column Widths
To ﬁt the width of one column, double click on right separator line in table header. To ﬁt several
columns widths, select multiple columns and double click on one of column separators in table
header.

See Also
Setting Column Formula
Expression Syntax
Table Sorting
Missing Values (NaN) in Tables and Calculations

Missing Values (NaN) in Tables and Calculations
In computing, NaN, which stands for Not a Number, is a value or symbol that is usually produced as a
result of an operation on invalid input operands. For example, most ﬂoating-point units are unable to
explicitly calculate the square root of negative numbers, and will instead indicate that the operation
was invalid and return a NaN result.
An invalid operation is not the same as an arithmetic overﬂow (which returns a positive or negative
inﬁnity). Arithmetic operations involving NaN always produce NaN, allowing the value to propagate
through a calculation so that errors can be detected at the end without extensive testing during
intermediate stages. A NaN does not compare equal to any number or NaN.
How does a NaN appear?
There are three kinds of operations which return NaN:
1. Operations with a NaN as at least one operand, e.g. 1+NaN
2. Indeterminate forms
Divisions 0/0, ∞/∞, ∞/-∞, -∞/∞, -∞/-∞
Multiplications 0*∞, 0*(-∞)
Power 1^∞
Additions ∞+(-∞), (-∞)+∞ and equivalent subtractions.
3. Real operations with complex results
Square root of a negative number
Logarithm of a negative number
Tangent of an odd multiple of 90 degrees (or π/2 radians)
Inverse sine or cosine of a number which is less than -1 or greater than +1.
http://magicplot.com/wiki/
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Examples

Expression Result
0^0
1
0/0
NaN
sqrt(-1) NaN
1/0
Infinity
-1/0
-Infinity

NaN in MagicPlot Tables
In MagicPlot NaN is also used to represent empty cells in Tables.
Statistical functions ignore NaN values in Tables.

NaN in Expressions
You can use predeﬁned constants NaN, nan or NAN in expressions to specify NaN value.
The isNaN(x) function checks if the argument is NaN.

Example

If you set a Column Formula if(col(B) >= 0, col(B), NaN), it will return only positive
values from column B. Negative values are replaced with NaN value. You can use this
expression to ﬁlter negative values if you do not want to use them in future calculations. Note
that ”Not-a-Number returned at row #” warning can be shown for such expressions.

Creating a Copy of Table, Fit Plot, Folder or Figure
You can create a full copy of selected project components (Tables, Fit Plots, Figures and entire
Folders) by selecting Create a Copy item on context menu.
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What Data is Plotted on the Copied Fit Plots and Figures
If the only Fit Plots and Figures are selected for creating a copy, the created Fit Plots and Figures will
use the data from the same tables and columns as the initial ones. If you select also the Tables which
contain plotted data, then the created Fit Plots and Figures will use the data from created copies of
these Tables.

Nonlinear Curve Fitting with Fit Plot
Nonlinear Curve Fitting: Fit Plot

http://magicplot.com/wiki/
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Creating a Fit Plot
Nonlinear least squares data ﬁtting (nonlinear regression) can be performed using Fit Plot. To create a
Fit Plot, select your X and Y columns in Table, then select Table → Create Fit Plot in the main
menu, or use the same item in the Table context menu, or use Create Fit Plot button in the
toolbar.

MagicPlot has been veriﬁed with NIST Datasets
National Institute of Standards and Technology (NIST) has created the Statistical Reference Datasets
Project which includes 26 datasets for testing the nonlinear ﬁt algorithms. MagicPlot has been
successfully tested on these datasets. Our report on MagicPlot testing with NIST datasets is available
here: Report.

Fitting Methodology
'Nonlinear' means here that analytical ﬁtting function depends nonlinearly on varying parameters (ﬁt
parameters). Fit procedure iteratively varies the parameters of the ﬁt function to minimize the
residual sum of squares. The nonlinear ﬁtting algorithm needs the user to set the initial values of ﬁt
parameters.
To ﬁt the data, implement these steps:
1.
2.
3.
4.

Create a Fit Plot, specify Y errors in Data tab of Curve Properties dialog for the data curve, if any
Specify ﬁt function by adding Fit Curves
Specify initial values of ﬁt parameters (drag curves or enter accurate values)
Specify used X data interval

MagicPlot Manual - http://magicplot.com/wiki/

Last update: Mon Jan 18 17:36:07 2021

manual

http://magicplot.com/wiki/manual

5. Run ﬁtting
You can undo ﬁt and also undo changing initial parameters as any other action using Undo function. It
is a handy feature when experimenting with diﬀerent models and initial parameters.
Further reading
This manual does not completely cover the complex nonlinear ﬁtting methodology. We recommend
you to take a look at this book:
H. Motulsky and A. Christopoulos, Fitting Models to Biological Data Using Linear and Nonlinear
Regression: A Practical Guide to Curve Fitting, 2004.

Fit Function is a Sum of Fit Curves
MagicPlot considers ﬁt function as a sum of Fit Curves. Ordinarily in peaks ﬁtting each Fit Curve
corresponds to one peak in experimental data. Click the Add button to add new Fit Curve to the list.
There is a number of predeﬁned Fit Curves types (Line, Parabola, Gauss, Lorentz, etc.) You can also
create a Custom Equation Fit Curve and manually enter the formula. Baseline ﬁtting components may
be added to the ﬁtting sum, too.
Fit Plot window contains the list of Fit Curves. Each Fit Curve in the list has three checkboxes:

http://magicplot.com/wiki/
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Show: Speciﬁes whether to show this Fit Curve on the plot. Active only if Baseline checkbox is
not set
Baseline: Toggles the subtracting of this Fit Curve from experimental data. You also can use
Residual button to subtract all Fit Sum from data
Sum: Speciﬁes whether to use this Fit Curve in sum ﬁt function
Below the Fit Curves list, is a parameters table which shows names, values, and descriptions of
parameters relating to the selected Fit Curve.
Fitting by Sum and Fitting One Curve
MagicPlot allows two alternatives buttons to run the ﬁt:
Fit by Sum button will ﬁt the data with the sum of Fit Curves for which the Sum checkbox is
set. Data interval from Fit Interval tab will be used. This button must be used for example
to ﬁt the spectrum with the sum of peaks.
Fit One Curve button will ﬁt the data with the one currently selected Fit Curve. The
individual interval for each Fit Curve will be used. Set Edit Interval checkbox to edit
individual interval for each Fit Curve.
Copying and Pasting Fit Curves
You can copy and paste Fit Curves from one Fit Plot to another Fit Plot or Figure. You can also paste
the copied Fit Curves to the same Fit Plot to create a copy.
The copy of Fit Curves with the same parameters and styles will be created if you paste Fit
Curves to a Fit Plot.
A link to the source Fit Curves will be inserted if you paste Fit Curves in a Figure.
Fit Curves Reordering
You can reorder Fit Curves by dragging them in the table. The data curve is always drawn the ﬁrst
and ﬁt sum is drawn the last.

Setting Initial Values of Parameters
Nonlinear ﬁtting assumes that certain initial values of parameters are set before ﬁtting. This
procedure is very easy if you use Fit Curves of predeﬁned types (not custom equation): you can drag
curves on the plot. Initial parameters values for each Fit Curve can also be set in the parameter table.
MagicPlot Manual - http://magicplot.com/wiki/
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Adjusting Parameters with Mouse Wheel
You can adjust Parameters in the table using mouse wheel scrolling when the mouse cursor is on the
desired parameter: Hold Ctrl key (Cmd key on Mac) and scroll. If the Shift key is also pressed the
parameter step for one wheel 'click' will be increased.

Guessing Peaks
If you are ﬁtting a spectrum with multiple peaks, MagicPlot may automatically add and approximately
locate peaks before ﬁtting. See Guessing Peaks for details. Guessed peaks should be used only as of
the initial estimate for ﬁtting: don't forget to click the Fit button after peaks are added.

Parameter Locking
You can lock (ﬁx) parameter(s) to prevent varying this parameter(s) during the ﬁt and to prevent its
changing due to set initial values by mouse dragging (for built-in functions). Set the checkbox in Lock
column in the parameter list to lock parameter.

Parameters Joining
MagicPlot allows joining (sometimes referred to as coupling, binding, linking) of ﬁt parameters of
diﬀerent Fit Curves. See Joining the Parameters of Fit Curves for details.

Weighting of Data Points Using Y Errors
MagicPlot allows the weighting of data points with Y error data. You can specify Y error data in Fit Plot
properties dialog. If no Y error data are speciﬁed weighting is not used.
http://magicplot.com/wiki/
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Weights are calculated as 1 / Yerror2 for every point. See Fitting Algorithm and Computational
Formulas for details.
Weights must be positive and ﬁnite for all points so the Y error values must be positive and non-zero
(to prevent inﬁnite weights). MagicPlot checks this condition before ﬁtting and shows an error
message if Y errors cannot be used to compute weights.

Specifying Fit Intervals
You can set the X intervals of the data which will be used for ﬁtting. Data points outside these
intervals are not used to compute the minimizing residual sum of squares. You can use this feature if
some data points (especially in the beginning or the end) are inaccurate, e.g. noisy.
Select Fit Interval tab to set intervals visually or edit accurate borders values in the table.
Double click on the interval to split it
Drag the interval border to move it. If intervals intersect, they will be merged
Use context menu on the plot to create, delete and split intervals
Note: Data intervals from the Fit Interval tab are used for ﬁtting Sum only. To set individual data
intervals for the one Curve ﬁtting use Edit Interval checkbox.

Baseline Fitting and Extraction
Fit Interval is also usable when baseline ﬁtting. Before baseline ﬁtting, you can specify the interval
which does not contain any signal points and contains baseline only. Set Baseline checkboxes at
baseline Fit Curves after baseline ﬁtting to subtract baseline from data. Then specify the whole
interval and ﬁt the data.
Note that if you use data processing (integration, FFT, etc.) on Fit Plot, then the diﬀerence between
MagicPlot Manual - http://magicplot.com/wiki/
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the data and baseline curves (which you do see on the plot) will be processed. You can use this
behavior to exclude baseline from data before integrating, see Integration for more information.

'Data-Baseline' Table Column
The 'Data-Baseline' column is appended to the Table with initial (X and Y) data when you create a Fit
Plot. The 'Data-Baseline' column contains the diﬀerence between initial Y data and baseline
approximation (the sum of Fit Curves for which Baseline checkbox is set). It is 'Data-Baseline'
column that is actually plotted on Fit Plot as data.
Use 'Data-Baseline' column in Table if you want to process the data without baseline. This column is
also used as initial data if you use Processing menu when Fit Plot is active.

Viewing the Residual Plot
Residual means here the diﬀerence between initial data, baseline function and Fit Sum function.
MagicPlot oﬀers two diﬀerent ways to view the residual:
Press and hold the Residual button. The residual will be shown while the button is pressed.
You can use either mouse or space key (if the button is selected) to hold Residual button.
You can either set Baseline checkboxes for all summed Fit Curves to subtract them from data
and explore the residual plot

Fitting
To execute the ﬁt click the Fit by Sum button of Fit One Curve button (see below).
MagicPlot indicates the ﬁt process with a special window. Fitting curves are periodically updated on
the plot while ﬁtting so you can see how ﬁt converges.

MagicPlot shows the current iteration number and deviation decrement with two progress bars while
the ﬁt is performed. The ﬁt process stops when one of these progress bars reaches the end.
You can see two buttons on ﬁt progress window:
Break Iterations: Breaks iterations after current iteration. Use this button if you suspect
that further iterations will not change the result.
Undo Fit: Breaks iterations and reverts ﬁt parameters to their initial (before ﬁt) values. Use
this button if you see that ﬁt process converges to wrong result; change initial values of
http://magicplot.com/wiki/
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parameters and run ﬁt again.

Fitting One Curve
You can use MagicPlot to ﬁt the data with single selected Fit Curve by pressing Fit One Curve
button. In this case, a speciﬁc data interval for each Fit Curve is used and the main ﬁtting data
interval (from Fit Interval tab) is ignored. Select Edit Interval checkbox in the bottom of the
Fit Plot panel to set speciﬁc ﬁt intervals for each Fit Curve.
Because of using individual data interval this method is useful for baseline ﬁtting. In order to ﬁt
baseline specify the intervals which do not contain signal (peaks) and contain only noise.

Why My Fit is Not Converged?
In some cases, the ﬁt procedure may fail to ﬁnd the optimal parameters values. The actual
mathematical reason for this error is the impossibility to invert the matrix α calculated from partial
derivatives of the ﬁt function with respect to ﬁt parameters. This inverted matrix is used to compute
the new values of parameters for the next step of ﬁt (like gradient descent). In most cases, this error
occurs when the matrix α is ill-conditioned or nearly singular and the inverse cannot be calculated
accurately enough with used ﬂoating-point arithmetic.

The origin of this error may be:

Fit is not converged through one or more parameters: some parameters were taking
unrealistically great values during iterations. There is no local minimum of residual sum of
squares near the initial values of these parameters. MagicPlot highlights the suspicious Fit
Curve in this case.
Mutual dependency exists between some parameters. The algorithm cannot resolve which
parameter to vary.
Fit function is ill-conditioned: the minimized residual sum of squares depends on some
parameters much more than on other ones.
Numeric overﬂow (or underﬂow) when calculating ﬁt function with initial parameter values or on
the next steps.
Try one of the following:

Specify more accurate initial values of parameters.
Simplify the ﬁt function (e.g. remove some peaks).
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Lock some parameters.

See Also
Fitting Algorithm and Computational Formulas
Specifying Custom Fit Equation
Using Spline for Baseline Subtraction
Joining the Parameters of Fit Curves
Guessing Peaks
Predeﬁned Fit Curves Equations
Calculating Integrals and Statistics on Intervals using Fit Plot
Export Curves as Table

Fitting Algorithm and Computational Formulas
MagicPlot uses iterative Levenberg–Marquardt
which is widely used in most software.

nonlinear least squares curve ﬁtting algorithm

MagicPlot implementation of Levenberg–Marquardt algorithm is optimised for using with multi-core
processors. MagicPlot successfully passed testing with NIST Nonlinear Regression datasets (see our
report).

Nonlinear Least Squares Algorithm
Fit procedure iteratively varies the parameters βk of ﬁt function f(x, β1, …, βp) to minimize the residual
sum of squares (RSS, χ2):
here:
xi and yi are the data points,
N is total number of points,
f(x, β1,…,βp) is the ﬁt function which depends on value of x and ﬁt parameters βk,
p is the number of ﬁt parameters βk,
wi are data weighting coeﬃcients for each point (xi, yi).
An initial guess for the parameters has to be provided to start minimization. Calculation of the new
guess of parameters on each ﬁt iteration is based on the ﬁt function partial derivatives for current
values of ﬁt parameters for each x value:
Partial derivatives are computed using explicit formulas (for some predeﬁned ﬁt functions) or with
ﬁnite diﬀerence (for custom equations).

Weighting of Data Points Using Y Errors
MagicPlot can use weighting of y values based on y errors si:
http://magicplot.com/wiki/
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If standard y errors si are speciﬁed: wi = 1 / si2 1);
Otherwise: all wi = 1.
In Fit Plot Properties dialog (Plot Data tab) you can set one of the following methods to
evaluate standard y errors si:
Get y errors from table column(s),
Percent of data for every point,
Fixed value or Standard deviation — do not use in weighting because in this case the error
values are the same for all data points.

Iterations Stop Criteria
After each iteration except the ﬁrst MagicPlot evaluates deviation decrement D:
Deviation decrement shows how the residual sum of squares (RSS) on current iteration relatively
diﬀers from that on the previous iteration.
The iterative ﬁt procedure stops on one of two conditions:
If the deviation decrements D for two last iterations is less than minimum allowable deviation
decrement, which is 10-9 by default
If the number of iterations exceeds maximum number of iterations, which is 100 by default
You can change the minimum allowable deviation decrement and maximum number of iterations in
Fitting tab of MagicPlot Preferences.

Formulas Used in Fit Report
In the table below you can ﬁnd the formulas which MagicPlot uses to calculate ﬁt parameters and
values in Fit Report tab.
Because of some confusion in the names of the parameters in diﬀerent sources (books and software),
we also give many diﬀerent names of same parameter in note column.
Parameter
Symbol
Name
Original Data and Fit Model Properties
Number of
used data
points

MagicPlot Manual - http://magicplot.com/wiki/
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Formula

Fit parameters β1,…,βp

—

Number of ﬁt
function
parameters β

—

Degrees of
freedom
Estimated
mean of data
Estimated
variance of
data
Data total sum
of squares
(TSS, SST)
Fit Result

TSS

Residual sum
of squares
(RSS)

http://magicplot.com/wiki/
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Note
For peak-like
functions (Gauss,
Lorentz) these
parameters are
amplitude,
position and half
width at half
maximum.
Only parameters
with unset Lock
checkbox are
taken into
account.
This is the total
number of
unlocked
parameters of ﬁt
curves which are
summarized to ﬁt.

Not used by ﬁt
algorithm, only for
comparison.
Also known as:
• Sum of squares
about the mean.
This value is
minimized during
the ﬁt to ﬁnd the
optimal ﬁt
function
parameters.
Also known as:
• 'Chi-squared'
• Sum of squared
residuals (SSR),
• Error sum of
squares (ESS),
• Sum of squares
due to error (SSE).
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Parameter
Symbol
Name
Original Data and Fit Model Properties

Reduced χ2

Residual
standard
deviation

s

Coeﬃcient
of
determination
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Note
The advantage of
the reduced chisquared is that it
already
normalizes for the
number of data
points and model
(ﬁt function)
complexity.
Also known as:
• Mean square
error (MSE),
• Residual mean
square.
Also known as:
• Root mean
square of the error
(Root MSE)
R2 will be equal to
one if ﬁt is
perfect, and to
zero otherwise.
This is a biased
estimate of the
population R2, and
will never
decrease if
additional ﬁt
parameters (ﬁt
curves) are added,
even if they are
irrelevant.
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Symbol
Name
Original Data and Fit Model Properties

Adjusted R2

Covariance
matrix of
parameters βk

Standard
deviation of
parameters βk
(std. dev.)
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Note
Adjusted R2 (or
degrees of
freedom adjusted
R-square) is a
slightly modiﬁed
version of R2,
designed to
penalize for the
excess number of
ﬁt parameters
which do not add
to the explanatory
power of the
regression. This
statistic is always
smaller than R2,
can decrease as
you add new ﬁt
curves or
introduce
parameters, and
even be negative
for poorly ﬁtting
models.
Here α is the
matrix of partial
derivatives of ﬁt
function with
respect to
parameters βm
and βn which is
also used by
ﬁtting algorithm to
compute
parameters for
next iteration.
These values are
displayed in Std.
Dev. column in
parameters table.

Printed on Mon Jan 9 17:44:32 2023

Mon Jan 9 17:44:32 2023

Parameter
Symbol
Name
Original Data and Fit Model Properties

21/97

Formula

Correlation
matrix of
parameters βk
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Note
This matrix shows
if the parameters
are linked. The
values lie in range
-1…1, diagonal
elements are
always 1. If two
parameters are
linked the
corresponding
matrix value will
be close to 1. It
means that
changing the ﬁrst
parameter
compensates
changing of the
second one so
that the ﬁtting
algorithm cannot
select between
them.

See Also
Nonlinear Curve Fitting: Fit Plot
Specifying Custom Fit Equation
Using Spline for Baseline Subtraction
Joining the Parameters of Fit Curves
Guessing Peaks
Predeﬁned Fit Curves Equations
Calculating Integrals and Statistics on Intervals using Fit Plot

Joining the Parameters of Fit Curves
In some cases you may want to ﬁt the data with two peaks with the same amplitude for example. You
can do this in two ways: by specifying custom Fit Curve with your equation or by joining the
'amplitude' parameters of two peaks.

MagicPlot Manual - http://magicplot.com/wiki/

Last update: Mon Jan 18 17:36:07 2021

manual

http://magicplot.com/wiki/manual

To join parameters of two or more Fit Curves select one of desired Fit Curves, then select desired
parameter in parameters table and press Join button in the bottom of the panel (or double click on
parameter). You can specify the selected parameters as equal or proportional by entering multiplier
and constant for each parameter. Joined parameters are shown with blue color (instead of black) in
curve parameters table in Fit Plot window. Joined parameters are treated as one parameter when
ﬁtting, so joining results in the reducing of actual model parameters number.
In the example above the areas and widths of tho peaks are joined and are equal. The positions of
maximums are joined and inverse: -1 multiplier is set to the width of Curve 3.
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See Also
Nonlinear Curve Fitting: Fit Plot

Specifying Custom Fit Equation
To specify custom ﬁt function formula, press Add button and select Custom Equation in popup
menu.
Enter your formula in y(x)= text ﬁeld below. Use x as ﬁt function argument. See Expression
Syntax for details.
You may recall last entered custom ﬁt functions using Recently Used Custom item in Add
popup menu.
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Fit Parameters
You can introduce Fit Curve parameters with any names except argument x, and constants like e, pi
(see predeﬁned constants for details):
Parameters names are case-sensitive (a and A are diﬀerent parameters).
Parameters names lengths are not limited.
Begin names with letter or _ sign. You can use numbers in the middle or in the end of the name:
a1, a_1, A1, a1t, but the names like 1a are not allowed.
The parameters you introduce in formula will automatically and immediately occur in parameters list,
you do not need to enter parameters names in the list manually. Random values are used as the
initial values of parameters. Do not forget to set more relevant initial values, otherwise ﬁt algorithm
may fail.

Adjusting Parameters with Mouse Wheel
You can adjust Parameters in table using mouse wheel scrolling when mouse cursor is on the desired
parameter: Hold Ctrl key (Cmd key on Mac) and scroll. If Shift key is also pressed the parameter step
for one wheel 'click' will be increased.

http://magicplot.com/wiki/
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See Also
Nonlinear Curve Fitting: Fit Plot
Using Spline for Baseline Subtraction
Predeﬁned Fit Curves Equations

Using Spline for Baseline Subtraction
You can use cubic spline to subtract baseline on Fit Plot. To create spline curve click on Add button in
Fit Curves tab of Fit Plot and select Spline menu item.
Do not use splines to subtract baselines which can be ﬁt well enough with Line curve (line or
constant baseline). You may mistakenly subtract wide peaks using spline. In some cases Parabola
curve may be more suitable.

Editing Spline
Created spline has three anchor points by default. You can move, add and remove anchor points:
Move anchor point with mouse
Double click on spline curve to add new anchor point
Double click on anchor point to remove it
Set Baseline checkbox in spline row in ﬁt curves table to subtract spline from data.

Fitting with Spline
Spline anchor point (x, y) coordinates are treated as ﬁt parameters so you can perform ﬁtting with
spline although we don't recommend this technique. Fitting the baseline with some adequate model
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function is preferred.
It is recommended to set appropriate ﬁt intervals which contain only baseline without peaks. In such
case Fit One Curve button is more acceptable than Fit by Sum button, because the individual
interval for current curve will be used and the interval from Fit Interval tab (which is used to ﬁt
by sum of curves) is ignored. Select spline curve and set Edit Interval checkbox in the bottom of
the panel to edit spline interval, then click on Fit One Curve button. The anchor point coordinates
will be varied but the number of points will remain. You also can lock some parameters (usually x
coordinates) by setting Lock checkboxes in parameters table.

See Also
Nonlinear Curve Fitting: Fit Plot
Specifying Custom Fit Equation
Guessing Peaks
Predeﬁned Fit Curves Equations
http://magicplot.com/wiki/
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Guessing Peaks
MagicPlot can approximately locate peaks in spectrum. To locate peaks click on Guess button in Fit
Curves tab of Fit Plot. Peaks are added at position of global extremum of data-baseline with
previous peaks subtracted.
When Guess Peaks window is open you can see the preview of guessed peaks on Fit Plot. This
preview is updated every time you change the parameters in the window.

See Also
Nonlinear Curve Fitting: Fit Plot
Specifying Custom Fit Equation
Using Spline for Baseline Subtraction
Predeﬁned Fit Curves Equations

Predeﬁned Fit Curves Equations
All predeﬁned Fit Curves are listed in this table. You also can specify custom ﬁt equation. Unlike
custom ﬁt equations these curves can be adjusted with mouse on Fit Plot.
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Line

Parabola

Spline

Natural cubic spline,
on each i-th piece:

Gaussian

Gaussian-A
(area-normalized)

Lorentzian

Lorentzian-A
(area-normalized)
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Parameters
Meaning
a — linear
b — constant
a—
quadratic
b — linear
c — constant
xN — anchor
point xcoordinates
yN — anchor
point ycoordinates
a—
amplitude
dx — half
width at half
maximum
(HWHM)
x0 —
maximum
position
a — area
(integral)
dx — half
width at half
maximum
(HWHM)
x0 —
maximum
position
a—
amplitude
dx — half
width at half
maximum
(HWHM)
x0 —
maximum
position
a — area
(integral)
dx — half
width at half
maximum
(HWHM)
x0 —
maximum
position

Additional
Properties

Vertex:

Area (integral):
Standard deviation:

Amplitude:
Standard deviation:

Area (integral):

Amplitude:
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Gauss Derivative

Lorentz
Derivative
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Parameters
Meaning
Parameters
are the same
as for
original
Gaussian:

Additional
Properties

Area of original
Gaussian
(second integral):
a—
Standard deviation:
amplitude
Peak-to-peak
dx — half
horizontal:
width at half Peak-to-peak
maximum
vertical:
(HWHM)
x0 — center
position
Parameters
are the same
as for
original
Area of original
Lorentzian:
Lorentzian
(second integral):
a—
Peak-to-peak
amplitude
horizontal:
dx — half
Peak-to-peak
width at half
vertical:
maximum
(HWHM)
x0 — center
position

See Also
Nonlinear Curve Fitting: Fit Plot
Using Spline for Baseline Subtraction
Guessing Peaks

Export Curves as Table
Fit Curves and Fit Sum are treated as function equations in MagicPlot Fit Plots. But in some cases (e.
g. to export and plot ﬁt data with other application) you may want to create (x, y) table with Fit
Curves y-values. For this purpose use Tools → Export Curves as Table menu item when Fit
Plot is active. This dialog is also available for Figures.
You can either add new Table to a Folder in current Project or export table to a text ﬁle.
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Data Processing
Setting Column Formula
There are two ways to set formula for column evaluation:

1. Select column and write formula in formula string.

2. Use Table → Set Column Formula menu item to open column formula dialog window. See
Expression Syntax for details.
http://magicplot.com/wiki/
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Row Index
Variable i contains the current row index. Rows are enumerated from 1.

Rows Evaluation Order
Rows are always evaluated one after another from the ﬁrst to the last in the speciﬁed range.
Accordingly the row number i is incremented after each step.

Example

You can use this behavior to calculate factorial: set 1 in the ﬁrst row of column A and after
that set formula cell(A, i-1) * i and rows interval from 2 to 100. Note that formula is to
be set for rows beginning from the second, and not from the ﬁrst. You will get the factorial of
row number (i).

Using Table Data
There are two functions to obtain current table cell values in formula:
col(A) – returns the value of cell in column A in the current (i-th) row. Equivalent to cell(A,
i).
cell(A, 3) – returns the value in column A and row 3.
You can use either upper-case letters (A…Z, e.g. col(B)) or numbers (1, 2, 3,.., e.g. col(1)) in
columns numeration in arguments of col and cell functions.
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Example

col(A) + 15 + cell(B, i+1)

Auto Recalculation on Data Change
MagicPlot can automatically recalculate formula when data in used columns are changed. Set Auto
Recalculate checkbox to enable this feature.

Example

Set formula col(A)*2 for column B and set Auto Recalculate checkbox. Column B will be
recalculated if you change values in column A or column A is updated by other formula or
processing algorithm (e.g. integral, derivative of other column).

Formula Menu in Column Context Menu
You can edit column formula and change auto recalculation mode from column context menu or menu
Table. Select exactly one column and open context menu to view this menu items.

“Argument is out of range at row #” Warning
Some mathematical functions can be deﬁned only on a certain interval. For example, square root
(sqrt(x)) is not deﬁned for negative numbers (all calculations in MagicPlot are made in real
numbers, not complex). Hence if the argument of sqrt is negative, a Not-a-Number (NaN) is
http://magicplot.com/wiki/
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returned. If a NaN value occurs in some part of formula, the result of calculation will also be a NaN,
and corresponding table cells will be empty.
The calculations are not terminated if NaN value occurs in some row(s).
In some cases you may want to check if a NaN values occurs in calculations. MagicPlot shows the
warning “Argument is out of range at row #”. This row number is the ﬁrst row in which NaN value
was returned. MagicPlot also highlights the function or operator which ﬁrst produces NaN value.

See Also
Expression Syntax

Expression Syntax
Formula editor is used in the following cases:
Setting Column Formula
Custom Fit Curve
Entering value in any numeric ﬁeld and in tables
MagicPlot Calculator
MagicPlot uses standard IEEE 754 double precision ﬂoating-point arithmetic. Double precision
ﬂoating point takes 8 bytes per number and provides a relative precision of about 16 decimal digits
and magnitude range from about 10-308 to about 10+308.
Syntax Highlighting
MagicPlot formula editor highlights expression syntax. It also marks matching brackets and highlights
variables:

General Rules
Case Sensitivity
MagicPlot formula translator is generally case sensitive, i.e. you can write sin but not Sin. Note
that x and X are diﬀerent variables. You can use this feature when naming Custom Equation Fit
MagicPlot Manual - http://magicplot.com/wiki/
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Curve parameters.
Entering Numbers
You can use dot (.) only as decimal separator, and separate function arguments with a
comma (,) in:
Setting Column Formula
Custom Fit Curve
Using MagicPlot Calculator
You can use dot (.) or comma (,) as decimal separator, and separate function arguments
with a semicolon (;) in the following cases:
Cell editing in Tables
Entering value in any numeric ﬁeld
You can use e or E for scientiﬁc notation: 1.45e-3 or 1.45E-3.
Using Spaces and Line Breaks
You can freely insert space characters and line breaks in formula, but do not break function names,
numbers, operators. You do not need to enter special characters to indicate line break.

Local variables in expression
You can set a local variables in expression. Use semicolon to separate variable assignments and the
result expression: a=5; a*a + 2*a + 1. The expression after the last semicolon is the result
expression. The variables are calculated in the present order so you need to assign the variable
before usage.

Functions
You can see a list of all available functions and their descriptions in Functions tab in Set Column
Formula window and in Help on Functions window which can be opened from menu in calculator
window.
MagicPlot uses functions of Java programming language library StrictMath to evaluate sin, cos,
exp, etc. These functions are available from the well-known network library netlib as a “Freely
Distributable Math Library”, fdlibm package. The same library is widely used in many scientiﬁc
computing applications.
Special functions (Bessel, Erf, Gamma, Beta) calculation is based on Colt 1.2 library.
Trigonometric Functions
MagicPlot supports all standard trigonometric functions (sin, cos, etc.). All angles are always
http://magicplot.com/wiki/

Printed on Mon Jan 9 17:44:32 2023

Mon Jan 9 17:44:32 2023

35/97

MagicPlot User Guide

measured in radians for clarity.
You can use the following functions to convert angles units:
deg(a) — converts angles input in radians to an equivalent measure in degrees.
rad(a) — converts angles input in degrees to an equivalent measure in radians.
Examples

sin(rad(90))
deg(asin(1))
Constants
The predeﬁned constants are:
pi, Pi, PI — π = 3.1416… value (the ratio of circumference of a circle to its diameter).
e — e = 2.7183… value (the base of the natural logarithms). Note: expression e^a is evaluated
as exp(a).
nan, NaN, NAN — Not-a-Number value.
inf, Inf, infinity, Infinity — positive inﬁnity value which may be used in some
calculations. Note: write -inf for negative inﬁnity.
eps — machine epsilon, gives an upper bound of the relative error due to rounding in ﬂoating
point arithmetic. Note: eps = ulp(1) = 2^(-52) = 2,2204E-16. (52 is the number of bits
used to store fractional part of a number.)

Boolean Logic
MagicPlot can interpret boolean logic expressions. Zero is interpreted as false and non-zero values
are interpreted as true similarly to C programming language (Note: legacy MagicPlot versions 2.9
and older interpret zero and negative values as false, this was changed in the 3.0 version). You can
use simple logical operators which are described below. Use 1 as true and 0 as false.
The conditional function 'if'
The conditional logical function is if(condition, a, b). If condition argument is true (nonzero) it returns the second argument (a), otherwise it returns the third argument (b).

Examples

if(col(A) >= 0, col(A), -col(A)) — evaluates absolute value of column A (you can
use abs(col(A)) for that, of course).
if(col(B) >= 0, col(B), NaN) — returns only positive values from column B. Negative
values are replaced with NaN value (empty cell). You can use this expression to ﬁlter negative
values if you do not want to use them in future calculations. Note that “Not-a-Number returned
at row #” warning can be shown for such expression.
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if(col(A) > 0 & col(B) > 0, max(col(A), col(B)), NaN)
a * if(x >= 0, x, -x) – custom ﬁt function example for abs.
Equality Checking
You have to be careful if you need to check equality of two values. Due to inaccuracy of computer
ﬂoating-point calculations the result of evaluation is always approximate. For example, result of
sqrt(3)^2 is the number 2.9999999999999996, not exactly 3. The expression sqrt(3)^2 == 3
is false (it returns 0). Keep in mind that for convenience MagicPlot rounds numbers when showing
on the screen, so this value will be shown as 3 in table if the number of shown fractional digits in
MagicPlot preferences is not big enough.
Generally, if you want to check equality of two values you need to use some equality threshold for
relative diﬀerence. That is, you should compare the modulus of relative diﬀerence of two values a and
b with threshold t: if(abs((a-b)/a) < t, …, …).

Examples

sqrt(3)^2 - 3 results something about -4,4409E-16
if(abs(sqrt(3)^2 - 3) / 3 < 1e-10, …, …) — checks equality of sqrt(3)^2 and 3
with a threshold of 1e-10.

Operators
Operator Description
+
addition
subtraction
*
multiplication
/
division
%
remainder after division
^
exponentiation
|
logical or
&
logical and

Operator Description
==
equal to
!=
not equal to
!
logical negation
<
less than
>
greater than
<=
less than or equal to
>=
greater than or equal to

Operations Priority
Operations
Precedence
Associativity
function()
1 (is evaluated ﬁrst) —
^
2
Right-to-left
!, - (unary minus) 3
—
*, /, %
4
Left-to-right
+, 5
Left-to-right
<, >, <=, >=
6
Left-to-right
==, !=
7
Left-to-right
&
8
Left-to-right
|
9
Left-to-right
= (assignment)
10 (is evaluated last) Left-to-right
http://magicplot.com/wiki/

Printed on Mon Jan 9 17:44:32 2023

Mon Jan 9 17:44:32 2023

37/97

MagicPlot User Guide

Operators with lower precedence value are evaluated earlier. You can use brackets to change
calculation sequence.
Expression is evaluated left-to-right, excluding repeated exponentiation operator ^. The ^ operator is
right-associative like in Fortran language (evaluated right-to-left; note that in general case
a^(b^c) ≠ (a^b)^c). Hence a^b^c is evaluated as a^(b^c). The reason for exponentiation being
right-associative is that a repeated left-associative exponentiation operation would be less useful:
Multiple appearances could (and would) be rewritten with multiplication: (a^b)^c = a^(b*c).

Examples

1 + 2 * 3 returns 7.
(1 + 2) * 3 returns 9.
2*-3 returns -6.
-3^2 is equal to -(3^2), because ^ priority is higher than that of unary minus. The result is -9.
(-3)^2 returns 9.
2^2^3 is equal to 2^(2^3), because ^ is right-associative operator. The result is 256.

Comments in formulas
You can insert comments in any formula using /*…*/ notation.
Press Ctrl+/ on Windows/Linux or Cmd-/ on Mac OS to comment selection. Comments can be multiline. Note that the single line comments using a symbol at the line start are not supported because
line breaks are not taken into account in MagicPlot formula syntax.

Table Sorting
To sort Table select Table → Sort Table menu item. You can sort the entire table or only selected
area (columns and rows selection). You can also use Sort by This Column item in Table context
menu (exactly one column must be selected).

Sorting Criteria

You may specify multiple sorting criteria columns. If the value in the ﬁrst criteria column are the same
MagicPlot will compare the values from the second criteria column if speciﬁed.
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Data Processing and Auto Recalculation
Processing of Selected Data
MagicPlot Pro supports the following processing methods available in Processing menu:
Smoothing
Integration
Diﬀerentiation
Fast Fourier Transform (forward and inverse)
Convolution
Deconvolution
Correlation
Histogram calculation
To process data ﬁrst select desired table columns or curves then select appropriate item in
Processing menu. Processing parameters dialog will be opened.
All processing algorithms except histogram require X and Y values to be set. Therefore select X
column along with Y column(s) if you are processing data from table.

Processing of Multiple Selected Data
Diﬀerent processing tools need diﬀerent number of input columns or curves. You can process multiple
selected columns of curves if one column or curve is enough for used processing method. Smoothing
for example has one curve input so you can select smooth multiple curves at time. Otherwise Fourier
transform need two (real and imaginary) curves so you cannot process multiple data with one click.
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Auto Recalculation on Input Data Change
MagicPlot can automatically recalculate formula when data in used columns are changed. Set Auto
Recalculate checkbox to enable this feature.

Editing Processing Parameters
You can edit processing parameters after processing using context menu of processing result (column
or curve). You can also change processing parameters of multiple selected curves which were
processed in the same way:
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See Also
Setting Column Formula

Smoothing
Open Table or Figure or Fit Plot with initial data and select Processing → Smooth menu item. The
opened processing dialog shows parameters, initial curves (semi-transparent) and smoothed preview.

Parameters
Periodic checkbox applies on calculation of ﬁrst and last p/2 points. When it is set MagicPlot will
take missing values from the opposite end (as if the signal is periodic) to calculate ﬁrst and last p/2
points.

Algorithms
Two algorithms are available: Central Moving Average and

Savitzky-Golay method.

Central Moving Average
Each value Ak is replaced with p-points average:
.
If Periodic checkbox is not set the ﬁrst and last p/2 points are calculated with the same
symmetrical formula but with less summands.
http://magicplot.com/wiki/
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Savitzky-Golay Filter
A Savitzky–Golay ﬁlter essentially performs a local polynomial regression on a series of equally
spaced data points. Each data point value is replaced with local polynomial value at this point.
If Periodic checkbox is not set, MagicPlot will repeat the values of the ﬁrst and last points to
calculate a polynomial for the ﬁrst and last p/2 points.

See Also
Data Processing and Auto Recalculation

Integration
Open Table or Figure or Fit Plot with initial data and select Processing → Integrate menu item.

Baseline Correction
If your initial data to be integrated contains a baseline (usually constant or linear), you may want to
subtract it from data before integrating. (A constant baseline will result in linearly growing integral.)
In such case the algorithm may be the following:
1.
2.
3.
4.
5.
6.

Create Fit Plot with your initial table data
Add a Fit Curve which simulates the baseline. You may specify a custom equation
Specify Fit Interval so that it contains only noise points
Fit the data by clicking Fit Sum button
Subtract the baseline ﬁtting curve from data by checking Baseline checkbox in curves list
Use menu Processing → Integrate to integrate the plotted data without baseline.
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Algorithm
To perform integration you should specify two columns: x and y. Missing values are ignored.
MagicPlot uses

trapezoidal rule to compute the integral:

See Also
Data Processing and Auto Recalculation
Diﬀerentiation

Diﬀerentiation
Open Table or Figure or Plot with initial data and use Processing → Differentiate menu item.

Algorithm
To perform diﬀerentiation you should specify two columns: x and y. Missing values are ignored.
MagicPlot uses

central diﬀerence formula to compute the derivative:

First and last points (i=1 and i=N) are computed as follows:
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See Also
Data Processing and Auto Recalculation
Integration

Fast Fourier Transform (FFT)
Open Table or Figure or Plot with initial data and use Processing → Fast Fourier Transform
menu item to perform FFT.
Fast Fourier transform algorithm computes discrete Fourier transform exactly and is used to
considerably speed up the calculations.
Note that FFT is not an approximate method of calculation.

Parameters

Sampling
Interval

Real,
Imaginary
Forward /
Inverse

Sampling interval of original data Δt is used to compute the data in resulting
sampling column. MagicPlot calculates sampling interval as a diﬀerence between
second and ﬁrst values in Sampling column. You can set sampling interval
manually in Sampling Interval ﬁeld.
Note that using of discrete Fourier transform implies that the samples in your
original data are equally spaced in time/frequency, i.e. the sampling interval is
constant. If the sampling interval is varying or real and/or imaginary data contains
empty cells in the middle, the result of discrete Fourier transform will be incorrect.
Columns with real and imaginary components of data.
If your data is purely real, select <none> imaginary item
Transform direction (here Inverse also equals to Backward)
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Divide forward transform result by number of points N (see formulas table). If your
original data is real, you may want to additionally multiply the result by 2 to get
the true amplitudes of real signal. Also referred as Normalize in some other
applications.
If selected, after forward Fourier transform the two parts of spectrum will be
rearranged so that the lower frequency components are in the center; the
opposite rearrangement of spectrum will be done before inverse transform if any.
Also referred as Shift FFT in some other applications.

Algorithm
MagicPlot uses the algorithm of FFT that does not necessarily require the number of points N to be an
integer power of 2, though in such a case evaluation is faster. MagicPlot uses jﬀtpack library (a Java
version of ﬀtpack).
Discrete Fourier Transform Formulas
By default MagicPlot uses 'electrical engineering' convention to set the sign of the exponential phase
factor of FFT: forward transform is computed using factor -1. Most scientiﬁc applications use factor
-1 in forward transform as MagicPlot does by default. But note that the sign of exponential phase
factor in Numerical Receipts in C, 2nd edition, p. 503 and in MATLAB package in forward transform is
+1.

1/N in forward
transform
Checked
(Default)
Unchecked

1/N in forward
transform
Checked
(Default)
Unchecked

Factor −1 (Default)
Forward Transform
Inverse Transform
(Signal→Spectrum)
(Spectrum→Signal)

Factor +1 (Scientiﬁc)
Forward Transform
Inverse Transform
(Signal→Spectrum)
(Spectrum→Signal)

Here cn are complex signal components and Cn are complex spectrum components, n = 1…N. The
only diﬀerence is in the sign of exponential phase factor and 1/N multiplier.
Note: if you expect to get the original data when doing an inverse FFT of forward FFT, set the 1/N in
Forward Transform, Center Zero Frequency and Factor options the same for forward and
inverse transforms.
Amplitude and Phase Columns Formulas
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Because of using atan2 function the phase is unwrapped and is in range (−π, π]. The result of
atan2(y, x) is similar to calculating the arc tangent of y/x, except that the signs of both
arguments are used to determine the quadrant of the result.
Sampling Column Formulas
Sampling column contains frequency samples if forward transform is performed and time samples in
case of inverse transform.
Center zero
frequency
Unchecked
Checked

Formula

Sampling Column Values

Here Δt is given sampling interval of initial data (time for FFT and frequency for IFFT), n = 1…N.
Missing Values in the Original Data
Fourier transform implies that the original samples are uniformly distributed in time (for forward
transform) or frequency (for inverse transform).
Missing values in the middle or in beginning of original data columns are treated as zeros, the
result of Fourier transform may be incorrect.
Missing values in the end of the column are ignored.

See Also
Data Processing and Auto Recalculation

Convolution and Deconvolution
Open Table or Figure or Fit Plot with initial data, select desired curves or columns and click
Processing → Convolution or Deconvolution menu item.
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Parameters
Linear/Circular radio buttons specify the signal to be treated as periodic or not.

Algorithm
MagicPlot computes convolution and deconvolution using FFT (see

Convolution_theorem).

See Also
Data Processing and Auto Recalculation

Correlation
Open Table or Figure or Fit Plot with initial data, select desired curves or columns and click
Processing → Correlation menu item.
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Parameters
Linear/Circular radio buttons specify the signal to be treated as periodic or not.

Algorithm
MagicPlot computes correlation using FFT (see

Cross-correlation theorem).

See Also
Data Processing and Auto Recalculation

Histogram Calculation
Open Table or Figure or Fit Plot with initial data and select Processing → Histogram menu item to
calculate histogram.
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Parameters
You can either set the bin size/count manually or specify auto binning criteria.
Bin Bounds
MagicPlot align the the lower limit of the ﬁrst bin exactly at the beginning of speciﬁed histogram
range (From ﬁeld). The upper limit of the last bin is calculated on the basis of the speciﬁed bin size
and may be greater than the speciﬁed right histogram limit (to ﬁeld) as shown on the screenshot
above. Enter round value in the From ﬁeld if you want the lower limit of the ﬁrst bin to be round.

Auto Binning Criteria
You can enter custom criteria in Auto Binning combo box:
Typing k=... means setting the number of bins k
Typing h=... means setting the bin size h.
You can use these parameters in the expression:
n — the number of data points
s — data standard deviation
m — data mean
min — data minimum
max — data maximum.
The default alternatives are:
— Default criteria in Excel, Origin and some other software
http://magicplot.com/wiki/
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— Scott's formula
— Sturges' formula
MISE optimisation — Shimazaki method. MagicPlot ﬁnds the minimum of Mean Integrated
Squared Error (MISE) for the number of bins from 2 to min(n/2, 20n1/2) where n is the
number of data points. See this paper and site for details: Shimazaki and Shinomoto, Neural
Comput 19 1503-1527, 2007, http://2000.jukuin.keio.ac.jp/shimazaki/res/histogram.html.
'Keep on Recalculation' Option
This option is used when the histogram is recalculated. Recalculation may be cause by input data
change (if Auto Recalculate checkbox is selected) or invoked manually (Recalculate menu item
in histogram table column context menu).

See Also
Data Processing and Auto Recalculation

Descriptive Statistics
Select Tools → Statistics menu item to open the statistics dialog. Statistics dialog shows
statistics on currently selected table columns or curves on plot. The statistics is updated every time
you activate diﬀerent windows or change the selection in active window. Select multiple instances in
one window (columns or curves) to view multiple statistics data.

Showed Statistical Properties
By default some statistical properties are not shown. Click Show button to select which properties you
want to calculate.

Statistical Functions in Column Formulas
You can also calculate statistics on table columns using column statistics functions when entering
column formula. See Functions tab in Set Column Formula dialog for column statistics functions
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description. These functions are also available in MagicPlot Student edition.

Computational Formulas
Central moments are calculated as follows (see table). All sums are calculated using
summation. Central moments are calculated on second pass after Mean calculation.
Property
n
Mean
Central moments

compensated

Formula
The number of non-empty cells

MagicPlot uses the following formulas to calculate statistics:
Property
Mean (expected value)
Variance
Standard deviation
Skewness
Kurtosis
Y Sum

Formula

Calculating Integrals and Statistics on Intervals using Fit
Plot
Setting of intervals in Fit interval tab of Fit Plot was initially intended for specifying the range of
data which are used for ﬁtting by sum of ﬁt curves. However, this tab can also be used to calculate
integrals and statistics on these intervals. Data-Baseline is used to calculate the results.

Peak Moments
MagicPlot can integrate data on selected intervals and calculate peak moments (x mean, variance,
skewness, kurtosis). Spectrum line is treated as probability distribution curve: x values are treated as
'independent variable' and y values are treated as 'probability'. Standard statistical formulas are used
to calculate moments (see below).
Statistical data and integrals are automatically updated if x or y data are changed or intervals are
changed.

http://magicplot.com/wiki/

Printed on Mon Jan 9 17:44:32 2023

Mon Jan 9 17:44:32 2023

51/97

MagicPlot User Guide

All statistical data are summarized in the intervals table:

Managing Intervals
Move interval borders with mouse. Double click on interval to split it at desired position. Right click
opens context menu from which new intervals can be created on free space and existing intervals can
be deleted or split.

Relative Integrals Calculation
MagicPlot can calculate relative integrals to compare the relative intensity of spectrum lines. To
compute relative integrals set Relative integrals checkbox. MagicPlot designate the smallest
integral as 1, but you can enter a custom value. If you want to set not the smallest integral as a
reference point, enter 1 ﬁrst and then enter the value of desired integral relative to 1 into this ﬁeld, so
that other integrals will be calculated relative to this new value.

Computational Formulas
Central moments are calculated as follows (see table). All sums are calculated using
summation. Central moments are calculated on second pass after Mean calculation.
Property
n
Y Sum (normalization)

Formula
The number of non-NaN (x,y) points
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Formula

Central moments

MagicPlot uses the following formulas to calculate intervals statistics:
Property
Integral

Formula
Calculated using
Trapezoidal rule

X Mean (expected value)
Variance
Standard deviation
Skewness
Kurtosis

See Also
Nonlinear Curve Fitting: Fit Plot
Using Spline for Baseline Subtraction
Descriptive Statistics

Batch Processing
Batch Processing
MagicPlot Batch Processing allows to automatically process multiple similar data in the same way
without programming (scripting) and recording of macro. One only have to ordinarily process the ﬁrst
data set manually and then use it as a template for processing of the rest data sets. Batch Processing
includes the processing of data itself and semiautomatic ﬁtting of the series of similar data.
Video Tutorial
Here is short video tutorial about batch processing: http://www.youtube.com/watch?v=L7RRraY6Dkc

Introduction
Batch Processing idea is based on creating a copy of project components (Tables, Figures, Fit Plots)
with formula links between them, pasting new data into the copy of source Table and recalculation of
depending data using formulas.
The Table which contains the imported data from the ﬁrst manually processed data set is called
Template Table.
For each ﬁle MagicPlot will:
http://magicplot.com/wiki/
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1. Create copies of Template Table and selected related components,
2. Paste new data to the leftmost columns of the copy of Template Table,
3. Recalculate all depending data in copies.

Fitting of series dialog will be opened after batch processing. This tool allows you to ﬁt multiple data
with the same model.

Capabilities
Batch Processing tool supports all MagicPlot data processing and visualization techniques:
Calculating Table column with speciﬁed formula,
Fourier transform,
Integration/diﬀerentiation,
Histogram calculation,
Creating of Figures and Fit Plots,
Nonlinear curve ﬁtting.
These features are not supported by Batch Processing tool:
Changing the sequence of columns with imported source data (inserting columns left, deleting
and moving these columns),
Table sorting and transposing.

Batch Processing Steps
It is supposed that you have a number of text (ASCII) ﬁles with similarly formatted source data to be
processed.
The overall processing steps are:
1. Import the ﬁrst text ﬁle from series (Project → Import Text Table… menu item) and
process it. You can add new columns with formulas, calculate some derivative data (histograms,
FFT, etc.), create Figures and Fit Plots. There is one simple restriction: Do not change the
sequence of leftmost columns with imported source data: do not insert columns left,
delete and move these columns. Table sorting and transposing is also not supported
in Batch Processing.
Create Fit Plot(s) and ﬁt your data if you want to ﬁt series.
2. Run Batch Processing by selecting Project → Import with Batch Processing… menu
item. In the opened ﬁle dialog select all rest ﬁles in the series except the ﬁrst ﬁle which has
been already processed. Use Shift and Ctrl to select multiple ﬁles.
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3. In 3 tabs of Batch Processing dialog:
1. Import Options: Check the ﬁle format settings.

2. Processing Template: Specify the Table with data from the ﬁrst ﬁle (already
processed) as Template Table. The program will automatically show the derivative
components with related data. You can also deselect some components to prevent
cloning.
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3. Files Order & Values: Set up the ﬁle names parsing to get some values to include
into summary table. Select the ﬁles sorting. Note that the already processed ﬁle will
always be the ﬁrst.

4. Click Batch Processing button to start processing. MagicPlot will create a copies of Template
Table and all derivative components and paste new data in the leftmost columns.
5. The Fitting Series dialog will be opened if some Fit Plots were processed.
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Fitting Series
The Fitting Series dialog will be opened after the batch processing ﬁnishes if some Fit Plots were
created during the processing. If more than one Fit Plot was created for Template (and for each data
set also), multiple tabs with Fit Plots will be shown in the window. Each tab will show one Fitting
Series.
The Fitting Series dialog window is a standard Fit Plot panel with the list if data sets and options
for the ﬁtting series added on the bottom. The Fit Plot interface is described here: Nonlinear Curve
Fitting: Fit Plot. The list of imported data sets to process is shown on the bottom left. Fit Plot panel
shows the data from the selected line. Each data set will be processed in the same way as shown in
the window:
1. The ﬁt curves will be copied from the template plot (ﬁrst in list) or from the (already ﬁtted)
previous plot depending on radio button selected (see more information below).
2. The baseline will be ﬁtted with curve (selected in drop box) and subtracted from the
experimental data.
3. The data will be ﬁtted with selected curve or sum curve (selected in drop box).

Curves and Initial Values of Parameters: from the Template or from Previous Fit Plot?
Please pay attention on the source curves alternative: from the template or from the previous data
http://magicplot.com/wiki/
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set. This setting manage which curves and initial values of parameters will be used for nonlinear
ﬁtting of each data set. The recommendations are the following:
Select Previous if your data in data set changes 'evolutionary': the values of parameters (ex.
peak positions) are changed progressively from one plot to another. This variant appears when
you examine the dependency of your data on some parameter. Example: you heat the sample
step by step and measure the spectrum; the temperature rises from one spectrum to another
and peaks are moved. Each plot is more similar to the previous one then to the ﬁrst one (the
template).
Select Template if all of your data sets are independent and no 'evolution' process can be seen
between plots. Each plot is more similar to the ﬁrst one (the template) then to the previous one.
Automatic and Step by Step Modes
You have 3 alternative buttons to process:
Process – processes the currently selected Fit Plot: The curves are copied from the previous or
the ﬁrst Fit Plot and ﬁtting is performed. All existing curves will be removed from current Fit Plot
before coping curves from previous/ﬁrst Fit Plot.
Process Next – opens and processes the next Fit Plot.
Process All Next – automatically processes all the Fit Plots next to the currently selected Fit
Plot. This option is equal to the manually pressing Process Next button until all Fit Plots will
be processed.
Semi-Automatic Mode
When using step-by-step batch processing (Process / Process Next buttons) you can change the
ﬁt for the currently selected plot. You can change the initial values of the parameters (move peaks
manually), add or remove peaks. Don't forget to launch the ﬁtting after the manual changing of the
curve list or the parameters values.
Summary Table
Summary Table will be created after ﬁnishing ﬁtting series. This table contains the values of all ﬁt
parameters and standard errors for all processed data sets. You can use this data to create a Figure
or Fit Plot or export it.
By default the values in Summary Table will be updated if the values of ﬁt parameters on Fit Plots
changes.
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Reopening Fitting Series Dialog

You can open Fit Series dialog using Fit Series Summary → Open Fitting Series
Dialog… in summary table.

Visual Data Navigation
Scale Scrolling for Data Navigation
MagicPlot provides useful plot data navigation (scale scrolling and zooming). Here are several tools
and methods:
Mouse wheel rotation inside the current Axes box scrolls x/y or zooms x/y scale. Ctrl and Shift
keys toggle the mode
Scale box zoom tool
Hand tool (only if the image zoom is 1x, otherwise the while image will be scrolled in window)
Right mouse button dragging always works as Hand tool (except Mac OS X)
http://magicplot.com/wiki/
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The scrollbars (only if the image zoom is 1x, otherwise the while image will be scrolled in
window)
Scale buttons on the toolbar.

Do not Confuse Scale Scrolling and Image Zoom
Scale scrolling aﬀects the x/y scale minimum and maximum values. Use scale scrolling for
data navigation
Image zoom enlarges the entire image. Use image zoom for accurate drawing of small objects.

Current Axes
If your Figure contains more than one Axes box, MagicPlot indicates which Axes are currently selected
with blue circle sectors in the corners of Axes box. The current Axes selection aﬀects the action of
scale buttons and Add to Selected Axes item in Table context menu. It also helps you to
distinguish the Axes when you change style in the Figure Properties dialog window.

See Also
Drawing on Figures and Fit Plots, Image Zoom and Objects Selection
Reading Plot Data, Measuring Distances, Curves Selection

Reading Plot Data, Measuring Distances, Curves Selection
MagicPlot shows mouse cursor data coordinates in status line. If you have several axes on one Figure,
cursor coordinates relative to selected axes are shown.

Crosshair Cursor
MagicPlot can draw crosshair cursor. To turn it on use View → Crosshair Cursor menu item.
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Reading Plot Data
MagicPlot denotes the data point under the mouse cursor with square brackets. The accurate table
value in this point along with table name, row and column numbers is shown in status line in the
bottom of main window in the following format:
Folder | Table [x column; y column][row] = (x value; y value)

Curve Context Menu
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Use context menu of the Curve to open table with data or to open properties dialog.

Measuring Data Distances with Scale Zoom Tool
You can use Scale Zoom tool to measure the distances on plots. MagicPlot shows the distance in
status line when you select zoom box by mouse dragging. You can press Esc or reduce box size to
zero before releasing mouse button to prevent zooming if you want only to see the distance. If
multiple axes are located under cursor MagicPlot will show the distance in terms of current axes
(showed with blue corners).

Selecting Curves in Turn Using Keyboard
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Curves on Figures and Fit Plots can be selected with mouse click. You can also select Curves in turn
using Arrow keys or Tab/Shift+Tab keys:
→ or ↓ or Tab selects the next Curve
← or ↑ or Shift+Tab selects the previous Curve.
If no Curves are selected the ﬁrst pressing on these keys will select the ﬁrst Curve. If the Figure
contains multiple Axes, the Curves in all Axes are accessible in turn by this method.

See Also
Scale Scrolling for Data Navigation

Quick Plot Tool
Quick Plot tool is used for viewing a plot of Table columns without adding new Figures to Project.
Select Tools → Quick Plot item to open this tool.
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When Quick Plot window is open select some columns in Table to view the plot.

Creating and Editing Figures
Creating a Figure
To create a Figure select desired columns (one for X and one or more for Y) in Table and select
Create Figure item in context menu. You also can use Create Figure button on the main
toolbar.
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A new Figure will be created and data selection dialog will be opened. Check the columns for plotting
in the right list and specify which column must be treated as X. The rest columns will be used as Y
values. So you can add multiple curves with diﬀerent Y and the same X column.

Adding and Arranging Axes Boxes on a Figure
Adding and Arranging Curves on Figure Axes
Specifying Axis Multiplier, Preﬁx and Suﬃx
Shifting Curves on Figure and Creating 2D Waterfall
Using Figure Templates

Color Map Plots
To create a Color Map Plot, open the Table with matrix data, open a context menu and select Create
Figure → Color Map item or use Create Figure button on the Toolbar.
Selection in the table is ignored, the whole table is used for plotting matrix.
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The Color Map Plot can be conﬁgured in the Properties dialog which can be opened by double click on
the Color Map or using the context menu.
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Specifying X/Y Data for Color Map Plot
X and Y data for plotting can be speciﬁed in the 'Data' tab of the Properties dialog. MagicPlot supports
3 alternatives for X and Y values for the plotting matrix:
1. Manual range
2. Values from ﬁrst row or column
3. Column from another table
The non-uniform (not equally spaced) data in the X/Y columns is supported. The values can also be
unsorted.

Color Map Plots and other Curves
In MagicPlot the Color Map Plot is treated as a generalized 'Curve', so it can be combined on a one
Figure with other Curves in the one Axes box. The Color Map Plot is shown in 'Components' list in
Figure properties dialog. The drawing sequence can be changed in this list.
The axes grid (if it is switched on) is drawn on top of the last (upper) Color Map Plot in the Axes box.
You can select, copy and paste Color Map Plots between Figures and Axes boxes as any other Curves.
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Customizing Color Map Plot
The most often used properties of a Color Map Plot can be changed on the Inspector toolbar (the
second row of main window toolbar). The full settings list is available in the Properties dialog which
can be opened by double click on the Color Map or from context menu.

The Color Map style and the legend color bar style can be edited in the Color Map Properties dialog:
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Customizing Color Map Palette
The Color Map palette can be customized by pressing the 'Customize' button on the 'Style' tab of the
Color Map properties dialog.
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The buttons below the color table are:
Insert Before – inserts a new line before the current selection. The default color and data level
values for the new line are calculated as the average of the values from the previous and the
next lines.
Remove – removes selected lines from table.
Distribute Evenly – evenly distributes levels and colors in selected lines or in the whole table
if less then 3 lines are selected.
Invert Sequence – inverts the sequence of colors; the new data levels are calculated as 1-L
where L is the initial level value.

Color Map Palette Presets
MagicPlot contains several build-in palette presets. After editing a palette you can also save your own
preset by pressing the 'Save Preset' button. The selected preset can be renamed or deleted using
'Menu' button.
Custom presets are saved in ﬁles with the .mppc extension. You can open the folder which contains
custom preset ﬁles using the 'Menu' button. Use the 'Reload Presets List' menu item after adding new
ﬁles in the presets folder.

Get More Palette Presets
More palette presets can be found on this page: Additional Color Map Palettes

Creating Palette from Color List
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You can import a palette from other applications or text ﬁles using the 'Menu' button. MagicPlot
supports RGB values and hexadecimal color codes.
The current palette setting will be overridden (this operation can be undone).

Pasting RGB(A) Values
You can paste red, green, blue values or red, green, blue, alpha values in the opened
dialog box. The values must be separated by comma, semicolon, tab or space, one color per line. The
both 0…1 and 0.255 values are automatically supported.
The comma as a decimal separator is supported only if values are separated by tabs or semicolons.
Otherwise the dot only must be used as a decimal separator.
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Pasting Hexadecimal Color Codes
Paste hexadecimal color codes in the opened window. The values can be with or without the '#'
preﬁx. The values must be separated by the new line, comma, semicolon, tab or space characters.

Technical notes
Exporting of a Vector Image
MagicPlot renders the Color Map Plot as a high-resolution raster image which is included into the
vector image ﬁle (EPS, PDF, SVG, EMF). Therefore the ﬁle size does not depend on the data matrix
dimensions. The resolution of the Color Map image is set by the DPI value in the 'Canvas' tab of the
Figure properties dialog.
http://magicplot.com/wiki/
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The Postscript (EPS) and EMF image format does not support the transparency in the color maps.
Palette Colors Storage
MagicPlot store palette colors as 4 ﬂoating-point numbers (Red, Green, Blue, Opacity). Note that even
if color components are represented in 0…255 range, the fractional digits still make sense if smooth
color interpolation is selected.
Color Interpolation
In the 'Smooth' and 'Manual Levels' color interpolation modes MagicPlot interpolates colors linearly in
the sRGB color space.
Bicubic Image Interpolation
MagicPlot supports 3 color map spatial interpolation modes: oﬀ (nearest neighbor), bilinear and
bicubic.
MagicPlot performs the bicubic interpolation using the cubic Hermite spline. For uniform (equally
spaced) x or y values this method is equal to the conventional bicubic interpolation algorithm
(which is widely used for the image resizing) with the coeﬃcient a=-0.5.

See Also
Additional Color Map Palettes

Adding and Arranging Axes Boxes on a Figure
You can add a new Axes box to a Figure using the Add menu either in the Figure window or in the
Figure properties dialog.
The Add & Arrange Axes as Table menu item can also be used for arranging of the existing
Axes boxes as a table.
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'Add and Arrange Axes as Table' Dialog
This dialog opens by selecting Add & Arrange Axes as Table menu item. It may be used for
adding new Axes boxes and for arranging the existing Axes boxes without adding a new one.
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Moving and Resizing of an Axes Box
Axes box can be moved and resized as any other drawn object on the Figure canvas
1. Click on the Axes box border to select it. The green markers identifying your selection appear.
2. Drag Axes box border to move the Axes box on Canvas.
3. Draw border marker to resize Axes Box.

The Using of Dimensions Toolbar toolbar can also be used to set exact Axes box size and position.
Open the Dimensions toolbar and select an Axes box to edit the values.
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See Also
Creating a Figure
Adding and Arranging Curves on Figure Axes
Specifying Axis Multiplier, Preﬁx and Suﬃx
Shifting Curves on Figure and Creating 2D Waterfall
Using Figure Templates
Drawing on Figures and Fit Plots, Image Zoom and Objects Selection

Adding and Arranging Curves on Figure Axes
The best way to create a Figure with desired data is to select x and y data columns in Table and use
Create Figure in Table context menu.
There are diﬀerent ways to add data to existing Figure:
Select x and y columns in table with data, open table context menu (right click) and select Add
to Selected Axes sub-menu. All currently opened Figures are listed in this sub-menu.
Open Figure Properties window and go to Axes Properties → Components tab. Here
you can select the Table in the project tree and press Add to Axes button.
Copy and paste Curve from Fit Plot or another Figure to your Figure.
You also can add Fit Curves or Fit Sum from Fit Plot to Figure.

Changing Curves Drawing Order
To change Curves drawing order and legend entries order open Figure Properties dialog and go
to Axes Properties → Components tab. Drag rows in table to reorder. You can also use Up and
Down buttons or press Alt + up/down keys (Option + up/down keys on Mac) to move selected row in
table up or down.
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See Also
Creating a Figure
Adding and Arranging Axes Boxes on a Figure
Specifying Axis Multiplier, Preﬁx and Suﬃx
Shifting Curves on Figure and Creating 2D Waterfall
Using Figure Templates

Shifting Curves on Figure and Creating 2D Waterfall
MagicPlot allows you to set individual x and y shifts for every Curve on Figure. This feature may be
used to compare several similar Curves on one Figure.
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Speciﬁed Curve shifts do not aﬀect your data and are used only for drawing current Figure.
Curve shifts can be set in X Shift and Y Shift columns in Axes Components table (scroll table
right if these columns are not visible). Waterfall menu contains items for making and resetting 2D
waterfall and reversing curves order.
Reset Shifts sets all x and y shifts to zero
Make Waterfall automatically calculates shifts and arranges Curves
Make Waterfall menu item opens waterfall window in which you can specify shift increment.
MagicPlot tries to guess handsome shift values on the basis of number of curves and current scale.

See Also
Creating a Figure
Adding and Arranging Axes Boxes on a Figure
Adding and Arranging Curves on Figure Axes
Specifying Axis Multiplier, Preﬁx and Suﬃx
Using Figure Templates
http://magicplot.com/wiki/
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Using Figure Templates
Figure Templates is a powerful tool for reusing axes layout of previously created Figures. To use
Figure Templates, open Figure Properties window and select Templates tab.
Templates are stored in a special folder in your operating system account proﬁle. Project ﬁles do not
contain templates; changes in Projects do not aﬀect Templates.

Saving Template from Figure
To create a template from Figure open the Figure Properties window, select Templates tab and press
'Save Template' button. Then enter the new template name in opened dialog window.
MagicPlot always saves all available information in the template (not regarding on checkboxes state).

Applying Template to a Figure
To apply template to ﬁgure open the Figure Properties window and select Templates tab. Select
desired template in the saved templates list. Then check or uncheck boxes with features to apply and
click on 'Apply Template' button.
When you apply a template to Figure, the properties are copied from template to Figure. Note that
the Figure style will not be changed if you change the template after you have applied it to Figure.
The project ﬁle is standalone and you do not need the template to open project.
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You can undo applying template in a standard manner (no need to close the Figure Properties
window).

See Also
Creating a Figure
Adding and Arranging Axes Boxes on a Figure
Adding and Arranging Curves on Figure Axes
Specifying Axis Multiplier, Preﬁx and Suﬃx
Shifting Curves on Figure and Creating 2D Waterfall

Drawing and Editing
Axes Style Editing
Axes style can be set in Figure Properties window (or Fit Plot Properties for Fit Plot). This
window contains multiple tabs with axes drawing settings.

Drawing on Figures and Fit Plots, Image Zoom and Objects
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Selection
You can draw the following kinds of objects on Figures and Fit Plots:
Text labels with formatting support
Lines
Arrows
Rectangles
Ellipses
Inserting images

Select an appropriate instrument in the toolbar to draw an object.
The properties of selected objects can be changed in the inspector toolbar (the second row of
toolbar).

Image Zooming
If you need to precisely draw some small objects you can zoom in the image using slider in right
bottom (Pro only).
There are several alternative ways to change the image zoom:
Scroll the mouse wheel at the image zoom slider
Ctrl+scroll (Cmd+scroll on Mac) mouse wheel at blank part of plot (outside all axes boxes)
The button 1x and Alt+click (Option+click on Mac) on plot ﬁts the image to the window.

Do not Confuse Scale Scrolling and Image Zoom
Scale scrolling aﬀects the x/y scale minimum and maximum values. Use scale scrolling for
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data navigation
Image zoom enlarges the entire image. Use image zoom for accurate drawing of small objects.

Objects selection
Every object can be selected by clicking on its border or inside it. Hold Ctrl key (Windows, Linux) or
Shift key (Mac OS) and click another object to add it to current selection.

Moving an Object Forward or Backward
When objects overlap, you can change the order of objects drawing. Use Bring to Front and Send
to Back items in object context menu (right click on object to open menu).

Changing Curves Order on Figure
You can change the order of drawing the curves on Figure. The curves order can be set in Figure
Properties window, Axes Properties tab → Components tab. Select desired curves in list, then
hold Alt and press up/down arrow keys. You may also use Move Up and Move Down items in
Waterfall button menu.

Snapping to Other Objects
When you drag an object or change its size, MagicPlot will try to snap the bounds of this object to
other objects. While snapping MagicPlot shows you a red ruler and an object to which the bounds are
snapping. If you do not want to align your objects this way, hold Ctrl key to disable snapping.
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See Also
Scale Scrolling for Data Navigation
Reading Plot Data, Measuring Distances, Curves Selection

Colours and Opacity Adjustment
In MagicPlot you can set the opacity of each object (curve, text label, rectangle, etc.) to make it semitransparent. Opacity is treated as a property of object color. You can set opacity in Opacity submenu in color pop-up menu which opens by clicking on color button. Opacity percentage is shown on
colour button.
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See Also
Creating Transparent Figures and Fit Plots

Creating Transparent Figures and Fit Plots
To create an image with transparent background open Figure Properties or Fit Plot
Properties dialog window and set Transparent Background radio button in Canvas tab.
The background of transparent Figures and Fit Plots is shown with a grey-and-white chequerboard. If
you are preparing a picture for a dark background you can change the colour of chequerboard to dark
grey by selecting View → Transparency Checkerboard in main menu.
In case of transparent background you can set the preview background colour in Image Preview
window.
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See Also
Colours and Opacity Adjustment

Using of Dimensions Toolbar
This toolbar is intended for precise setting of the position and size of one or more selected drawn
objects on Figure or Fit Plot.
You can open Drawing Dimensions toolbar by selecting Tools → Drawing Dimensions in main
menu. Dimensions toolbar may be left opened.

Drawing Dimensions toolbar shows the coordinates and size of currently selected object(s). You can
also specify the coordinates or size of several components.
The x value is measured from the left edge of the canvas.
The y value is measured from the top edge of the canvas.
For rectangle or ellipse the speciﬁed coordinates determine the position of the upper-left
corner.
For text label:
x determines the left edge, center or right edge of text according to text alignment of
label.
y determines the baseline position of the ﬁrst line.
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For line or arrow the speciﬁed coordinates determine the position of the beginning.

Switching Curves Antialiasing on the Screen

Antialiasing oﬀ
You can toggle curves
main menu.

Antialiasing on

antialiasing (smoothing) by selecting View → Curves Antialiasing in

Please note that antialiasing may slow down the drawing if you have many data points (~100K).

Text Labels Editing
Inserting Special Symbols and Greek Letters
MagicPlot supports any

Unicode symbols, including Greek letters and many special symbols.

The help on inserting Greek letters and special symbols is also available in Help menu.

Typing Greek letters with Keyboard Shortcuts
To insert Greek letter type Ctrl+G (Command G on Mac OS) and then type Latin letter mentioned in
the table below.
Greek Letter Name Greek Symbol
Alpha
Beta
Gamma
Delta
Epsilon
Zeta
Eta
Theta
http://magicplot.com/wiki/

Αα
Ββ
Γγ
Δδ
Εε
Ζζ
Ηη
Θθ

On Keyboard
(Ctrl+G, then)
Aa
Bb
Gg
Dd
Ee
Zz
Hh
Qq
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Greek Letter Name Greek Symbol
Theta (alt.)
Iota
Kappa
Lambda
Mu
Nu
Xi
Omicron
Pi
Rho
Sigma
Tau
Upsilon
Phi
Phi (alt.)
Chi
Psi
Omega

ϑ
Ιι
Κκ
Λλ
Μμ
Νν
Ξξ
Οο
Ππ
Ρρ
Σσ
Ττ
Υυ
Φφ
ϕ
Χχ
Ψψ
Ωω

MagicPlot User Guide

On Keyboard
(Ctrl+G, then)
J
Ii
Kk
Ll
Mm
Nn
Xx
Oo
Pp
Rr
Ss
Tt
Uu
Ff
j
Cc
Yy
Ww

Inserting Math Symbols with Keyboard Shortcuts
To insert math symbol type Ctrl+M (Command M on Mac OS) and then type symbol mentioned in the
table below.
Symbol name

Symbol

Multiplication sign
Middle dot (multiplication)
Division slash
Minus sign
Plus-minus sign
Minus-plus sign
Not equal
Inﬁnity

×
·
∕
−
±
∓
≠
∞

On Keyboard
(Ctrl+M, then)
* or x
. (dot)
/
+
=
n
8

To see the full list of shortcuts select Help → Insert Greek Letters and Math menu item.

Inserting Special Characters by Character Sequences
To insert the following special characters, simply type character sequences, as shown in the table
below. Character sequences will be replaced with special characters when you exit the edit mode (but
only if selected font contains required symbols).
You can disable auto replacing in Typography tab of MagicPlot Preferences.
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Em dash
—
En dash
–
Ellipsis
…
Much less than
≪
Much greater than
≫
Less than or equal to
≤
Greater than or equal to
≥
Plus-minus sign
±
Minus-plus sign
∓
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sequence
---...
<<
>>
<=
>=
+/-/+

Unicode Code Point Finding out
MagicPlot shows in status bar the Unicode code point of character highlighted in text label. To
view code point select exactly one character in text label in Figure of Fit Plot.

See Also
Advanced Typography Features

Advanced Typography Features
MagicPlot provides accurate typography in text labels and axes labels. You may toggle some features
in 'Typography' tab of MagicPlot Preferences.
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Ligatures Support
MagicPlot supports Latin ligatures in text labels. If you type 'ﬁ', 'ﬂ', etc., those symbols will be
shown with ligature glyphs when you exit edit mode.
Edit mode

Result
MagicPlot supports at least the following ligatures:
fi, fl
ff, ffi, ffl
Not all fonts contain ligature glyphs. MagicPlot displays ligatures only if the glyphs are included in
used font. You can turn the ligatures oﬀ in MagicPlot preferences.

Mathematical Symbols in Axes Labels
The numbers in scientiﬁc notation need two special characters if you want the typography to be
accurate: minus sign and multiplication sign. Many graphing software applications which use
simpliﬁed typography use letter 'x' and hyphen-minus (-) in numbers instead of typographically
correct special characters. This simpliﬁed typography was mainly used in old applications which do
not support Unicode.
MagicPlot can use either correct symbols (default) or simpliﬁed. You can change this option in
MagicPlot Preferences.
MagicPlot Manual - http://magicplot.com/wiki/
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Minus Sign
Various minus-like characters are used in diﬀerent cases and have diﬀerent height and length. The
height and length of minus sign are equal to those of plus sign and correspond to the size of digits in
the font. Here is a comparison of these characters:

When you edit some text, keyboard minus key enters hyphen-minus character. The correct minus
character can be typed in text label by pressing Ctrl+M, -, see Inserting Special Symbols for
details.
Multiplication Sign
In diﬀerent languages, multiplication signs diﬀer. In most cases you have to use either '·' or '×' sign.
You also can specify any special character or character sequence, for example enter spaces before
and after multiplication signs.
Multiplication sign
Correct minus sign
Middle dot
Correct minus sign
Simpliﬁed typography:
Latin letter 'x'
hyphen-minus instead of minus

See Also
Inserting Special Symbols and Greek Letters

Image Exporting and Copying
Image Export
To export Figure or Fit Plot image click on Project → Export Image menu item or use
corresponding toolbar button. You can set various options of ﬁle export format by clicking on Format
Options button in Export Image dialog window.
You can also copy image to clipboard.

http://magicplot.com/wiki/

Printed on Mon Jan 9 17:44:32 2023

Mon Jan 9 17:44:32 2023

91/97

MagicPlot User Guide

Raster Image Formats
The following lossless

raster graphics formats are supported:

PNG — the most suitable format for Fit Plots and Figures
GIF — supports only 256 colours and no transparency, out-of-date format
BMP — uncompressed raster format (large ﬁle size)
Setting the resolution of exported raster image
Image resolution for raster export can be set individually for every Figure and Fit Plot in Canvas tab
of the Properties window. The default resolution is 300 DPI.
Why is MagicPlot not capable to export images in JPEG format?
JPEG is a commonly used format of lossy compression for photographic images. The JPEG
compression algorithm is at its best on photographs and paintings of realistic scenes with smooth
variations of tone and color. However, JPEG is not suited for line drawings and other textual or iconic
graphics, where sharp contrasts between adjacent pixels cause noticeable artefacts. Such images are
better saved in a lossless raster graphics format such as BMP, GIF, PNG or vector graphics formats.
PNG and JPEG Comparison

PNG

2)

JPEG

Vector Image Formats
The following

vector graphics formats are supported:

PDF
EPS
SVG — most suitable for web publications
EMF — the most suitable format for inserting in Windows applications like Microsoft Oﬃce
Export in vector graphics formats by virtual printer
You also can use third-party virtual printer software to save an image in vector graphics format (use
Project → Print menu item).
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Image Format Restrictions
BMP:
Transparent background is not supported.
GIF:
Transparent background is supported but semi-transparency is not. Only 256 colours.
EMF and vector copy on Windows:
No semi-transparent colors (but transparent background is supported).
Image may be opened without antialiasing in some applications.
Text tracking changing is not supported
EPS:
Transparency is available only in Acrobat Distiller. Set Allow Pdfmark Transparency
checkbox in EPS format options, add /AllowTransparency true into Acrobat Distiller's
.joboptions ﬁle.
Transparent images inserted on plots will have solid color background.
Raster image copying:
Transparent background is not supported.

See Also
Copying Images to Clipboard
Preview Image

Preview Image
Use Project → Image Preview menu item to open image preview window. You can also use the
Preview button of the toolbar or Ctrl+Shift+P keyboard shortcut (Cmd+Shift+P on Mac).

Preview Features
In preview mode you can:
Preview in gray scale
Transparent images can be previewed on selected background color
Change the zoom of the image

http://magicplot.com/wiki/
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Preview Zoom Options
There are several options for the size of preview:
Percent of real size. Note: The size will be actually real only if the dots per inch (DPI) is
correctly set in your operating system
Fit to Window, Fit Width, Fit Height — ﬁts the size of previewed image to window
dimensions
Pixel-to-Pixel — allows you to see the accurate image that you will get using export in
raster image format. The resolution of exported raster image is evaluated as a product of
canvas size and DPI value speciﬁed in Canvas tab of Figure/Fit Plot Properties window.

Copying Images to Clipboard
When you edit a presentation or report, it is very useful to paste images from MagicPlot to another
application directly through clipboard without saving them.
MagicPlot supports copying images to clipboard in both raster and vector formats from Edit menu.
Transferring vector images is always preferable because these images are scaled more precisely.
However, we have found that some applications do not support pasting vector images, or paste
vector images with distorted text. In this case, please use copying raster image.

See Also
Image Export
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Tools
MagicPlot Calculator
MagicPlot Calculator is a useful formula calculator built in MagicPlot. To open calculator use Tools →
Calculator menu item.

Using calculator outside MagicPlot
Calculator window stays on top when MagicPlot main window is minimized to task bar (Dock on Mac),
so you can use the Calculator when working with other applications.

Using the Calculator
Type expression like (12+4)*sin(pi/2) and press Enter to get the result
Type a=5 to set variable a to 5
Use Up/Down keys to recall previously entered expressions
Use ans variable or press Ctrl+Up to insert the result of latest operation
Standard functions and variables (sin, cos, pi, e, etc.) are supported
MagicPlot Calculator uses the same Expression Syntax as other formula ﬁelds in MagicPlot application.

See Also
Expression Syntax

Appendices
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Keyboard Shortcuts
MagicPlot keyboard shortcuts are almost the same in diﬀerent operating systems (Windows, Mac OS,
UNIX-like). The main diﬀerence is in modiﬁer keys used: Ctrl on PC (Windows, UNIX-like) and
Command on Mac. Some shortcuts were altered to avoid coincidences with system ones.
You can ﬁnd these keyboard shortcuts in MagicPlot by selecting Help → Keyboard Shortcuts
menu item.

Mac Keyboard Symbols

⌘ Command (Meta) key
⇧ Shift key
⌥ Option (Alt) key
⌃ Control key

Common Shortcuts
Windows and UNIX-like Key Mac OS Key Action
Ctrl+O
⌘O
Open project
Ctrl+S
⌘S
Save project
Ctrl+Shift+S
⌘⇧S
Save project as
Ctrl+N
⌘N
New project
Ctrl+Shift+N
⌘⇧N
New table
Ctrl+I
⌘I
Import table from text ﬁle
Ctrl+Shift+I
⌘⇧I
Import table from clipboard
Ctrl+P
⌘P
Print (image or table)
Ctrl+Shift+P
⌘⇧P
Preview image
Ctrl+E
⌘E
Export image or table
Ctrl+K
⌘K
Open calculator
Ctrl+U
⌘U
MagicPlot preferences
Ctrl+Q
⌘Q
Quit
Undo/Redo
Ctrl+Z
⌘Z
Undo
Ctrl+Shift+Z or Ctrl+Y
⌘ ⇧ Z or ⌘ Y Redo
Ctrl+Shift+H
⌘⇧H
Show command history window
Clipboard
Ctrl+X
⌘X
Cut
Ctrl+C
⌘C
Copy
Ctrl+V
⌘V
Paste
Ctrl+A
⌘A
Select all

Table Shortcuts
Windows and UNIX-like Key
F2 or Double click
MagicPlot Manual - http://magicplot.com/wiki/
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Double click

Action
Edit cell
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Windows and UNIX-like Key
Mac OS Key Action
Ctrl+F2
⌘ F2
Set or edit column formula
F4
F4
Rename column (edit header)
Ctrl+Enter
⌘ Return
Recalculate column
Alt+Drag header
⌥ Drag header Rearrange table columns
(Win/Meta+Drag header on UNIX)

Figure and Fit Plot Shortcuts
Windows and UNIX-like Key Mac OS Key
Alt+Enter
⌥ Return
Arrows keys
Arrows keys
Shift+Arrows keys
⇧ Arrows keys
Escape
Escape
Delete or Backspace
Delete or Backspace
F2 or Double click
F2 or Double click
Moving and Resizing Drawings
Ctrl+Drag object

⌘ Drag object

Shift+Drag corners

⇧ Drag corners

Alt+Drag corners

⌥ Drag corners

Action
Open Figure or Fit Plot properties window
Move selected object(s) by 1 mm
Move selected object(s) by 0.1 mm
Clear selection
Delete selected objects
Edit selected text label
Disable rulers and snapping to other
objects
For rectangle and ellipse: preserve aspect
ratio
For line and arrow: disable snapping to 0°,
45°, 90°…
For rectangle and ellipse: stretch relative
to center

Text Labels Editing 3)
Ctrl+Enter or Shift+Enter
⌘ Return or ⇧ Return
Escape
Escape
Enter
Return
Ctrl+G, then letter
⌘ G, then letter
Ctrl+M, then symbol
⌘ M, then symbol
Ctrl+B
⌘B
Ctrl+I
⌘I
Ctrl+O
⌘O
Ctrl+U
⌘U
Ctrl+L
⌘L
Ctrl+E
⌘E
Ctrl+R
⌘R
Ctrl+J
⌘J
Ctrl+–
⌘–
Ctrl++
⌘+
Scale Range Scrolling and Zoom

Apply changes
Apply changes
New line
Type Greek letter (letters correspondence)
Type special math symbol (symbol list)
Bold
Italic
Oblique
Underlined
Align left
Center
Align right
Justify
Subscript
Superscript

Scrolling 4)

Vertical (Y) scale scrolling

Shift+Scrolling
Ctrl+Scrolling
Ctrl+Shift+Scrolling
http://magicplot.com/wiki/

Scrolling

⇧ Scrolling or Horizontal
Horizontal (X) scale scrolling
scrolling
⌘ Scrolling
Vertical (Y) scale zooming
⌘ ⇧ Scrolling or ⌘
Horizontal (X) scale zooming
Horizontal scrolling
Printed on Mon Jan 9 17:44:32 2023

Mon Jan 9 17:44:32 2023

97/97

Windows and UNIX-like Key Mac OS Key
Left mouse button+Scrolling ⌃ Scrolling
Image Zoom
Ctrl++
⌘+
Ctrl+– or Alt+Click
⌘ – or ⌥ Click
Ctrl+* or Ctrl+0
⌘ * or ⌘ 0

MagicPlot User Guide

Action
Proportional (X and Y) scale zooming
Zoom in
Zoom out
Full view

1)

Corrected in MagicPlot 2.7: weights wi are not normalized anymore. In MagicPlot 2.5.1 and earlier the
sum of weights was normalized to 1. This changing only aﬀects the resulting Chi square value in the
ﬁt report if Y error column(s) are set.
2)

If you use Opera browser with Opera Turbo option the images will appear recompressed in JPEG
format and this comparison is void.
3)

These shortcuts are activated in text label edit mode.
4)

Scrolling here means mouse wheel rotation or touchpad vertical scrolling.

From:
http://magicplot.com/wiki/ - MagicPlot Manual
Permanent link:
http://magicplot.com/wiki/manual
Last update: Mon Jan 18 17:36:07 2021

MagicPlot Manual - http://magicplot.com/wiki/

