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System Requirements and First Launch

MagicPlot is a cross-platform application based on Java technology. Java Runtime is included in the
MagicPlot distributive for Windows and Mac OS X.

Running MagicPlot on Linux/Unix

You need Java Runtime Environment (JRE) of version 11 or later to run MagicPlot 3.0. You can install
Java using the package manager or get a free compiled copy here: https://adoptopenjdk.net/.

Run MagicPlot using command: path-to-jre/bin/java -XX:MaxRAMPercentage=75 -jar
MagicPlot.jar.
Here -XX:MaxRAMPercentage=75 means maximum heap memory usage 75% of free memory.

First Launch

MagicPlot does not need any installation procedure.
Place MagicPlot executable folder to the directory you prefer.
MagicPlot preferences and registration data are stored in your operating system profile and are
individual for each account.

Opening Projects on Double Click

Windows

To make Windows open your MagicPlot project files (.mppz) in MagicPlot just open context menu of
one project file in Explorer and select Open With → Choose Program item. In the opened window
press Browse button and choose MagicPlotPro.exe or MagicPlotStudent.exe file. Select the
Always use the selected program to open this kind of file checkbox and click OK.

Mac OS X

MagicPlot project files (.mppz) will be automatically associated with MagicPlot by your operating
system.

http://magicplot.com/wiki/magicplot_wiki_home
http://magicplot.com
https://en.wikipedia.org/wiki/Java
https://en.wikipedia.org/wiki/Java
https://adoptopenjdk.net/
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Getting Started: Tables, Figures, Fit Plots and Undo

MagicPlot Projects contain Tables, Figures and Fit Plots. MagicPlot Project files have .mppz extension.

Tables contain numeric or text data.
Fit Plots are intended for non-linear curve fitting and subtracting baselines.
Figures are intended to graphically represent multiple data.

Close Unused Internal Windows

Feel free to close currently unused interval windows with Tables, Figures and Fit Plots. The data will
not be deleted, the window will be closed only. You can open the closed window by double clicking on
component in Project tree.

Where to start?

In most cases you may start with importing table from text file by clicking Project → Import Text
Table menu item.

Creating Figures and Fit Plots

The easiest way to create Figure or Fit Plot is the following:

Select two columns (x and y) in Table containing your data
Select Create Figure or Create Fit Plot item in the Table context menu
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You may also use Create Figure or Create Fit Plot buttons in the toolbar.

Enter Expressions in any Numeric Field

MagicPlot can evaluate simple expressions entered in any numeric text field (brackets are supported,
see Expression Syntax for details.) For example, you can enter 12/pi in circle width and height fields
in Dimensions toolbar if you want its perimeter to be equal to 12 (remember that p=πd, where p is
perimeter and d is diameter):

Importing Table from Text File (ASCII)

Use Project → Import Text Table menu item to import table(s) from text file(s), also referred
to as ASCII file(s).
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You may select multiple files in opened standard file dialog by holding Ctrl or Shift.

If you open multiple files, you can select the file to preview in files drop-down list (in Text
Input Preview frame)
If you select incorrect file(s) by mistake, click on Open icon to open file dialog once again and
select other file(s).
You can set Create Figure or Create Fit Plot checkbox to create Figure of Fit Plot after
importing:

If you select Figure, the created Figure will contain all imported data from all files
If you select Fit Plot, one Fit Plot will be created for each imported file

You can enlarge a part of the preview plot by selecting an area by mouse (scale box zoom tool).
Use context menu of the plot to change scale zoom to default.
F5 key reloads the text file or reloads the data from clipboard.

Command Line Arguments and 'Silent' Import

MagicPlot opens files which come as the command line arguments on launch. MagicPlot Project files
(.mppz) are detected as projects, the all other files are treated as the text files and the Import dialog
is opened. The text files will be imported in the current opened project.
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The -silent key in command line forces MagicPlot to import text files without opening import dialog.
The previously used import setting are used in such case. If Fit Plot or Figure creation was selected in
Import dialog last time, the new plots will be created.
Example for Windows OS: MagicPlotPro.exe mydata.txt -silent

Please make sure that your firewall software does not block MagicPlot loopback (127.0.0.1) request.

Table Editing

In MagicPlot Tables are used to store numeric or text data depending on column type (numeric/text).

Data Types

MagicPlot supports these data types in Tables:

Format Description
Numeric 64-bit double precision floating-point numbers ( IEEE 754)
Text Unicode string with unlimited length

Data type is set for entire columns. One column may not contain data with different types.
Empty cells are equivalent to Not-a-Number values.
Values from text columns are treated as empty cells if used as numbers.

Changing Column Type

Use Set Column Type menu in column context menu to change column type (numeric/text).

Columns Numbers

Columns are enumerated starting with 1. The first 26 columns are additionally denoted with Latin
letters: A, B, C, … Y, Z, 27, 28, 29, …. You can use either numbers or letters, addressing
cells and columns in formulas.

Renaming Columns

Double click on column header to rename table column. You can also use Rename Column context
menu item or press F4.

Moving (Reordering) Columns

Hold Alt key (Option on Mac, Meta/Win on Unix-like) and drag column header to rearrange table
columns. If Alt key is not pressed, mouse dragging on header will select the columns.

https://en.wikipedia.org/wiki/IEEE754
https://en.wikipedia.org/wiki/IEEE754
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Editing Table

You can edit table cell by double clicking on it. You can enter either a number or an expression using
Expression Syntax.

Fit Column Widths

To fit the width of one column, double click on right separator line in table header. To fit several
columns widths, select multiple columns and double click on one of column separators in table
header.

See Also

Setting Column Formula
Expression Syntax
Table Sorting
Missing Values (NaN) in Tables and Calculations

{{page>[nan]}}
{{page>[fitting]}}
{{page>[custom_fit_equation]}}
{{page>[spline]}}
{{page>[guess_peaks]}}
{{page>[fit_equations]}}

Export Curves as Table

Fit Curves and Fit Sum are treated as function equations in MagicPlot Fit Plots. But in some cases (e.
g. to export and plot fit data with other application) you may want to create (x, y) table with Fit
Curves y-values. For this purpose use Tools → Export Curves as Table menu item when Fit
Plot is active. This dialog is also available for Figures.

You can either add new Table to a Folder in current Project or export table to a text file.
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Page moved to Expression Syntax.

{{page>[set_column_formula]}}
{{page>[integration]}}
{{page>[differentiation]}}
{{page>[fft]}}
{{page>[transform_xy]}}
{{page>[interval_statistics]}}

Axes Style Editing

Axes style can be set in Figure Properties window (or Fit Plot Properties for Fit Plot). This
window contains multiple tabs with axes drawing settings.
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{{page>[axes_components]}}
{{page>[add_axes]}}
{{page>[templates]}}

Drawing on Figures and Fit Plots, Image Zoom and Objects
Selection

You can draw the following kinds of objects on Figures and Fit Plots:

Text labels with formatting support
Lines
Arrows
Rectangles
Ellipses
Inserting images

Select an appropriate instrument in the toolbar to draw an object.

The properties of selected objects can be changed in the inspector toolbar (the second row of
toolbar).
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Image Zooming

If you need to precisely draw some small objects you can zoom in the image using slider in right
bottom (Pro only).

There are several alternative ways to change the image zoom:

Scroll the mouse wheel at the image zoom slider
Ctrl+scroll (Cmd+scroll on Mac) mouse wheel at blank part of plot (outside all axes boxes)
The button 1x and Alt+click (Option+click on Mac) on plot fits the image to the window.

Do not Confuse Scale Scrolling and Image Zoom

Scale scrolling affects the x/y scale minimum and maximum values. Use scale scrolling for
data navigation
Image zoom enlarges the entire image. Use image zoom for accurate drawing of small objects.

Objects selection

Every object can be selected by clicking on its border or inside it. Hold Ctrl key (Windows, Linux) or
Shift key (Mac OS) and click another object to add it to current selection.

Moving an Object Forward or Backward

When objects overlap, you can change the order of objects drawing. Use Bring to Front and Send
to Back items in object context menu (right click on object to open menu).
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Changing Curves Order on Figure

You can change the order of drawing the curves on Figure. The curves order can be set in Figure
Properties window, Axes Properties tab → Components tab. Select desired curves in list, then
hold Alt and press up/down arrow keys. You may also use Move Up and Move Down items in
Waterfall button menu.

Snapping to Other Objects

When you drag an object or change its size, MagicPlot will try to snap the bounds of this object to
other objects. While snapping MagicPlot shows you a red ruler and an object to which the bounds are
snapping. If you do not want to align your objects this way, hold Ctrl key to disable snapping.

See Also

Scale Scrolling for Data Navigation
Reading Plot Data, Measuring Distances, Curves Selection

{{page>[scale_navigation]}}
{{page>[curves]}}
{{page>[shift_curves]}}
{{page>[colors]}}
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{{page>[transparent]}}
{{page>[dimensions]}}
{{page>[special_symbols]}}
{{page>[typography]}}
{{page>[point]}}

Image Export

To export Figure or Fit Plot image click on Project → Export Image menu item or use
corresponding toolbar button. You can set various options of file export format by clicking on Format
Options button in Export Image dialog window.

You can also copy image to clipboard.

Raster Image Formats

The following lossless raster graphics formats are supported:

PNG — the most suitable format for Fit Plots and Figures
GIF — supports only 256 colours and no transparency, out-of-date format
BMP — uncompressed raster format (large file size)

Setting the resolution of exported raster image

Image resolution for raster export can be set individually for every Figure and Fit Plot in Canvas tab
of the Properties window. The default resolution is 300 DPI.

Why is MagicPlot not capable to export images in JPEG format?

JPEG is a commonly used format of lossy compression for photographic images. The JPEG
compression algorithm is at its best on photographs and paintings of realistic scenes with smooth
variations of tone and color. However, JPEG is not suited for line drawings and other textual or iconic
graphics, where sharp contrasts between adjacent pixels cause noticeable artefacts. Such images are
better saved in a lossless raster graphics format such as BMP, GIF, PNG or vector graphics formats.

PNG and JPEG Comparison 1)

PNG JPEG

https://en.wikipedia.org/wiki/raster graphics
https://en.wikipedia.org/wiki/raster graphics
https://en.wikipedia.org/wiki/Portable_Network_Graphics
https://en.wikipedia.org/wiki/Portable_Network_Graphics
https://en.wikipedia.org/wiki/GIF
https://en.wikipedia.org/wiki/GIF
https://en.wikipedia.org/wiki/BMP_file_format
https://en.wikipedia.org/wiki/BMP_file_format
https://en.wikipedia.org/wiki/JPEG
https://en.wikipedia.org/wiki/lossy compression
https://en.wikipedia.org/wiki/JPEG
https://en.wikipedia.org/wiki/lossy compression
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Vector Image Formats

The following vector graphics formats are supported:

PDF
EPS
SVG — most suitable for web publications
EMF — the most suitable format for inserting in Windows applications like Microsoft Office

Export in vector graphics formats by virtual printer

You also can use third-party virtual printer software to save an image in vector graphics format (use
Project → Print menu item).

Image Format Restrictions

BMP:
Transparent background is not supported.

GIF:
Transparent background is supported but semi-transparency is not. Only 256 colours.

EMF and vector copy on Windows:
No semi-transparent colors (but transparent background is supported).
Image may be opened without antialiasing in some applications.
Text tracking changing is not supported

EPS:
Transparency is available only in Acrobat Distiller. Set Allow Pdfmark Transparency
checkbox in EPS format options, add /AllowTransparency true into Acrobat Distiller's
.joboptions file.
Transparent images inserted on plots will have solid color background.

Raster image copying:
Transparent background is not supported.

See Also

Copying Images to Clipboard
Preview Image

{{page>[image_preview]}}
{{page>[copy_image]}}

MagicPlot Calculator

MagicPlot Calculator is a useful formula calculator built in MagicPlot. To open calculator use Tools →
Calculator menu item.

https://en.wikipedia.org/wiki/vector graphics
https://en.wikipedia.org/wiki/vector graphics
https://en.wikipedia.org/wiki/PDF
https://en.wikipedia.org/wiki/PDF
https://en.wikipedia.org/wiki/Encapsulated_PostScript
https://en.wikipedia.org/wiki/Encapsulated_PostScript
https://en.wikipedia.org/wiki/Scalable_Vector_Graphics
https://en.wikipedia.org/wiki/Scalable_Vector_Graphics
https://en.wikipedia.org/wiki/Enhanced_Windows_Metafile
https://en.wikipedia.org/wiki/Enhanced_Windows_Metafile
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Using calculator outside MagicPlot

Calculator window stays on top when MagicPlot main window is minimized to task bar (Dock on Mac),
so you can use the Calculator when working with other applications.

Using the Calculator

Type expression like (12+4)*sin(pi/2) and press Enter to get the result
Type a=5 to set variable a to 5
Use Up/Down keys to recall previously entered expressions
Use ans variable or press Ctrl+Up to insert the result of latest operation
Standard functions and variables (sin, cos, pi, e, etc.) are supported

MagicPlot Calculator uses the same Expression Syntax as other formula fields in MagicPlot application.

See Also

Expression Syntax

Keyboard Shortcuts

MagicPlot keyboard shortcuts are almost the same in different operating systems (Windows, Mac OS,
UNIX-like). The main difference is in modifier keys used: Ctrl on PC (Windows, UNIX-like) and
Command on Mac. Some shortcuts were altered to avoid coincidences with system ones.

You can find these keyboard shortcuts in MagicPlot by selecting Help → Keyboard Shortcuts
menu item.

Mac Keyboard Symbols

⌘ Command (Meta) key
⇧ Shift key
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⌥ Option (Alt) key
⌃ Control key

Common Shortcuts

Windows and UNIX-like Key Mac OS Key Action
Ctrl+O ⌘ O Open project
Ctrl+S ⌘ S Save project
Ctrl+Shift+S ⌘ ⇧ S Save project as
Ctrl+N ⌘ N New project
Ctrl+Shift+N ⌘ ⇧ N New table
Ctrl+I ⌘ I Import table from text file
Ctrl+Shift+I ⌘ ⇧ I Import table from clipboard
Ctrl+P ⌘ P Print (image or table)
Ctrl+Shift+P ⌘ ⇧ P Preview image
Ctrl+E ⌘ E Export image or table
Ctrl+K ⌘ K Open calculator
Ctrl+U ⌘ U MagicPlot preferences
Ctrl+Q ⌘ Q Quit

Undo/Redo
Ctrl+Z ⌘ Z Undo
Ctrl+Shift+Z or Ctrl+Y ⌘ ⇧ Z or ⌘ Y Redo
Ctrl+Shift+H ⌘ ⇧ H Show command history window

Clipboard
Ctrl+X ⌘ X Cut
Ctrl+C ⌘ C Copy
Ctrl+V ⌘ V Paste
Ctrl+A ⌘ A Select all

Table Shortcuts

Windows and UNIX-like Key Mac OS Key Action
F2 or Double click Double click Edit cell
Ctrl+F2 ⌘ F2 Set or edit column formula
F4 F4 Rename column (edit header)
Ctrl+Enter ⌘ Return Recalculate column
Alt+Drag header
(Win/Meta+Drag header on UNIX) ⌥ Drag header Rearrange table columns

Figure and Fit Plot Shortcuts

Windows and UNIX-like Key Mac OS Key Action
Alt+Enter ⌥ Return Open Figure or Fit Plot properties window
Arrows keys Arrows keys Move selected object(s) by 1 mm
Shift+Arrows keys ⇧ Arrows keys Move selected object(s) by 0.1 mm
Escape Escape Clear selection
Delete or Backspace Delete or Backspace Delete selected objects
F2 or Double click F2 or Double click Edit selected text label
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Windows and UNIX-like Key Mac OS Key Action
Moving and Resizing Drawings

Ctrl+Drag object ⌘ Drag object Disable rulers and snapping to other
objects

Shift+Drag corners ⇧ Drag corners
For rectangle and ellipse: preserve aspect
ratio
For line and arrow: disable snapping to 0°,
45°, 90°…

Alt+Drag corners ⌥ Drag corners For rectangle and ellipse: stretch relative
to center

Text Labels Editing 2)

Ctrl+Enter or Shift+Enter ⌘ Return or ⇧ Return Apply changes
Escape Escape Apply changes
Enter Return New line
Ctrl+G, then letter ⌘ G, then letter Type Greek letter (letters correspondence)
Ctrl+M, then symbol ⌘ M, then symbol Type special math symbol (symbol list)
Ctrl+B ⌘ B Bold
Ctrl+I ⌘ I Italic
Ctrl+O ⌘ O Oblique
Ctrl+U ⌘ U Underlined
Ctrl+L ⌘ L Align left
Ctrl+E ⌘ E Center
Ctrl+R ⌘ R Align right
Ctrl+J ⌘ J Justify
Ctrl+– ⌘ – Subscript
Ctrl++ ⌘ + Superscript
Scale Range Scrolling and Zoom
Scrolling 3) Scrolling Vertical (Y) scale scrolling

Shift+Scrolling ⇧ Scrolling or Horizontal
scrolling Horizontal (X) scale scrolling

Ctrl+Scrolling ⌘ Scrolling Vertical (Y) scale zooming

Ctrl+Shift+Scrolling ⌘ ⇧ Scrolling or ⌘
Horizontal scrolling Horizontal (X) scale zooming

Left mouse button+Scrolling ⌃ Scrolling Proportional (X and Y) scale zooming
Image Zoom
Ctrl++ ⌘ + Zoom in
Ctrl+– or Alt+Click ⌘ – or ⌥ Click Zoom out
Ctrl+* or Ctrl+0 ⌘ * or ⌘ 0 Full view

1)

If you use Opera browser with Opera Turbo option the images will appear recompressed in JPEG
format and this comparison is void.
2)

These shortcuts are activated in text label edit mode.
3)

Scrolling here means mouse wheel rotation or touchpad vertical scrolling.
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