MagicPlot Manual

Plotting and nonlinear fitting software

User Tools

Site Tools


launch

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
launch [Mon Nov 9 01:30:34 2015]
Alexander
launch [Wed Jun 29 12:55:36 2016] (current)
Alexander
Line 1: Line 1:
 ====== System Requirements and First Launch ====== ====== System Requirements and First Launch ======
-MagicPlot is a cross-platform application based on [[wp>​Java]] technology. You need to install Java software (Java Runtime Environment,​ also referred to as the Java Runtime, Runtime Environment,​ Runtime, JRE, Java Virtual Machine, Virtual Machine, Java VM, JVM, VM) with version not older than **6**. Java 6 is also referred to as Java 1.6.+MagicPlot is a cross-platform application based on [[wp>​Java]] technology. You need to install Java software (Java Runtime Environment,​ also referred to as the Java Runtime, Runtime Environment,​ Runtime, JRE, Java Virtual Machine, Virtual Machine, Java VM, JVM, VM) with version not older than **7**. Java 6 is also referred to as Java 1.7.
  
 ===== Where to get the Java Virtual Machine? ===== ===== Where to get the Java Virtual Machine? =====
Line 7: Line 7:
   * **Unix-like system users:** [[http://​java.com|java.com]] or [[http://​openjdk.java.net/​install/​|openjdk.java.net/​install/​]] ​   * **Unix-like system users:** [[http://​java.com|java.com]] or [[http://​openjdk.java.net/​install/​|openjdk.java.net/​install/​]] ​
     * If you run MagicPlot jar-file from command line, set the maximum Java heap size by specifying the following parameters: \\ ''​java -Xmx1024m -jar magicplot.jar''​     * If you run MagicPlot jar-file from command line, set the maximum Java heap size by specifying the following parameters: \\ ''​java -Xmx1024m -jar magicplot.jar''​
-    * MagicPlot may not launch on old versions of OpenJDK Java Runtime (version 1.6.0_18 ​is enough) which may be installed by default on your Unix-like system. In such case update OpenJDK Java Runtime or install JVM from [[http://​java.com|java.com]].+    * MagicPlot may not launch on old versions of OpenJDK Java Runtime (version 1.is enough) which may be installed by default on your Unix-like system. In such case update OpenJDK Java Runtime or install JVM from [[http://​java.com|java.com]].
  
 ===== First Launch ===== ===== First Launch =====
launch.txt ยท Last modified: Wed Jun 29 12:55:36 2016 by Alexander